Download it now!
Bug 50961 - text background color for lines and shapes
Summary: text background color for lines and shapes
Status: RESOLVED DUPLICATE of bug 45028
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 04:44 UTC by Valerio Messina
Modified: 2016-05-04 09:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a named arrow as appear in Draw (3.55 KB, image/png)
2012-06-11 04:44 UTC, Valerio Messina
Details
a named arrow as appear in Visio (6.43 KB, image/png)
2012-06-11 04:45 UTC, Valerio Messina
Details
named arrow in Visio with background (9.98 KB, image/png)
2012-07-11 09:56 UTC, Valerio Messina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valerio Messina 2012-06-11 04:44:08 UTC
Created attachment 62886 [details]
a named arrow as appear in Draw

is usefull a (automatic) text background color feature for lines (and shapes).
As now a named arrow appear Strikethrough, see attached "arrowNamedDraw".
Visio has this feature, see attached "arrowNamedVisio".
Comment 1 Valerio Messina 2012-06-11 04:45:09 UTC
Created attachment 62887 [details]
a named arrow as appear in Visio
Comment 2 Joel Madero 2012-07-09 18:11:31 UTC
You can manually edit the text to move it above or below the line. But the example you showed from Visio does indeed look nice. Making this a lowest priority enhancement. 

Thanks for reporting.
Comment 3 Valerio Messina 2012-07-09 21:56:35 UTC
how do you move the text of a named arrow?
Comment 4 Joel Madero 2012-07-09 22:22:41 UTC
Highlight text, right click, click on "Text...", add a number to "Spacing to borders". For instance to move it up 2 inches add a 2" bottom border and it'll push it up. An example that I did awhile back:

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 5 Valerio Messina 2012-07-09 22:37:21 UTC
ok thank you for explanation of a workaround
Comment 6 Valerio Messina 2012-07-11 09:56:41 UTC
Created attachment 64102 [details]
named arrow in Visio with background

this show the text background color
Comment 7 Heiko Tietze 2016-05-04 08:10:16 UTC

*** This bug has been marked as a duplicate of bug 45028 ***
Comment 8 Valerio Messina 2016-05-04 09:52:18 UTC
bug 45028 seems related to connectors and not lines and shapes like this one.
So please mark this as duplicate but be sure to add a note on that bug to solve the trouble with simple lines too ot this RFE will be lost.