Bug Hunting Session
Bug 51188 - EDITING: "Undo" causes bizarre results after moving one end of a connector.
Summary: EDITING: "Undo" causes bizarre results after moving one end of a connector.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.0.1 target:6....
Keywords:
Depends on:
Blocks: Undo-Draw
  Show dependency treegraph
 
Reported: 2012-06-17 21:46 UTC by Sean Santos
Modified: 2018-02-13 10:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Santos 2012-06-17 21:46:51 UTC
Steps to reproduce:

1. Create a connector (ends can be attached to an object, or not).
2. Drag one endpoint to another location (attached to a glue point or not). The new location must change the relative order in the x direction (e.g. endpoint A goes from the left of endpoint B to the right) or in the y direction, or both.
3. Hit undo.

Expected results:

Connector returns to its original state, as it was just before the move.

Actual results:

- The connector does not return to its original shape, but does change size/location. (I have occasionally seen changes in color if the color was changed.) Even if all control points return to their original locations, routing might still change! (Because a vertical-horizontal-vertical pattern can change to a horizontal-vertical-horizontal one.)

- The connector sometimes cannot be selected, because it is not "actually" located in the place where it is displayed.

- Other connectors connected to the moving connector (e.g. attached to its midpoint) may move about in strange ways.

- Copying/pasting the connector may change its shape and/or location relative to other objects. This is easiest to see if you simply duplicate an Impress slide containing a buggy connector, in which case the routing is likely to change.

- For at least some formats, saving and then reopening the file will cause both the buggy connector, and copies of it, to change locations and shapes (not always in the same way!). For instance, this can happen with .ppt format.

Here is a quick list of bugs that are probably related (it's difficult to say "duplicate", because there are several features of these bugs and it's hard to tell which ones truly have the same root cause):

Selection buggy behavior from moving the endpoint of a connector in the same way (without undo): https://bugs.freedesktop.org/show_bug.cgi?id=44534

Probable duplicate of the above, mentioning a different (?) strange interaction with undo:
https://bugs.freedesktop.org/show_bug.cgi?id=45772

The same buggy behavior from moving the endpoint of a connector to a new glue point (does not specify relative x/y positions of result):
https://bugs.freedesktop.org/show_bug.cgi?id=50314

Copy/paste of connector between Writer and Impress not preserving routing:
https://bugs.freedesktop.org/show_bug.cgi?id=37968

Copy/paste within Impress and duplication of slide not preserving shape:
https://bugs.freedesktop.org/show_bug.cgi?id=34130
Comment 1 David Tardon 2012-07-17 12:39:42 UTC
well, this is a metabug of sorts, but there is a problem with connectors and undo
Comment 2 Julien Nabet 2015-08-22 18:48:28 UTC
Just an update to tell that bugs quoted are either fixed or duplicated of fixed/WFM ones.
However, I can still reproduce this one on pc Debian x86-64 with master sources updated yesterday.
Comment 3 Xisco Faulí 2017-09-11 08:49:18 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 4 Commit Notification 2017-12-15 08:03:25 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98de1ed2e2c49ea52f398f666aef7480b60e4e3c

tdf#51188: notify that geometry has changed when dragging the connector.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-12-19 19:19:28 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15946e60b8f38ed978883baec97e487e88824ff6&h=libreoffice-6-0

tdf#51188: notify that geometry has changed when dragging the connector.

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-12-31 07:34:38 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4173798ef73d3fc7da8c5b8fa575a36f05cd6f83

tdf#51188: allow connector gluepoint undo

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-01-10 11:42:37 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37052f28ff18a0d74c482f6169a3d02a7bd960fa&h=libreoffice-6-0

tdf#51188: allow connector gluepoint undo

It will be available in 6.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-02-12 18:44:48 UTC
A polite ping to Mark Hung: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 9 Friedrich Lobenstock 2018-02-12 19:01:58 UTC
I can confirm that this bug has been fixed on OpenSuSE Tumbleweed running Libreoffice version 6.0.0.2.0+.
Comment 10 Xisco Faulí 2018-02-13 10:36:58 UTC
(In reply to Friedrich Lobenstock from comment #9)
> I can confirm that this bug has been fixed on OpenSuSE Tumbleweed running
> Libreoffice version 6.0.0.2.0+.

Closing as VERIFIED FIXED.
Thanks for checking!!