Bug 51331 - Writer jumps to the middle of document when trying to edit OLE object
Summary: Writer jumps to the middle of document when trying to edit OLE object
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-22 04:51 UTC by schummer.m
Modified: 2012-10-09 14:20 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schummer.m 2012-06-22 04:51:11 UTC
When trying to edit an OLE object like a drawing in a document with >1 page, Writer always jumps somewhere in the middle of the document, regardless where the drawing is actually positioned within the document. This makes it necessary to scroll all the way through the document to the position where the OLE object is situated before you can edit it.

Steps to reproduce:
1) Create document in writer containing several pages.
2) Insert OLE object (drawing) at the end of the document (Insert->Object->OLE Object->drawing)
3) double-click on created OLE object

Result:
Writer jumps to another (random?) position somewhere in the middle of the document.

This also happens when inserting an already existing drawing as OLE object.
This behavior was only reproducable in OS X, but not in Linux for me.
Comment 1 Uwe Altmann 2012-10-09 14:20:48 UTC
Works for me in 3.5.4.2 and 3.6.2.