Bug 51343 - Windows installer: The progress bar for the installation resets several times
Summary: Windows installer: The progress bar for the installation resets several times
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-22 11:08 UTC by Stefan Knorr (astron)
Modified: 2012-06-27 22:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-06-22 11:08:51 UTC
During the installation of LibreOffice on Windows, the progress bar which is supposed to show the progress of the installation starts from 0 multiple times, as files are copied, the registry is modified etc.
It would be good to make sure it never resets, so the progress bar can actually fulfill its function of showing installation progress. (Otherwise, it is useless to most end users since they don't know how many tasks the installer does.)

The best way to go about this is probably to time several installations and then average out how much time each task took.
Comment 1 Andras Timar 2012-06-23 10:59:23 UTC
It is a duplicate of http://www.aerotaskforce.com/view/596 :)
Comment 2 Stefan Knorr (astron) 2012-06-27 22:41:50 UTC
Ouch.

In any case, I have checked again and it actually resets just once (but it stops for some time at the end).

FTR, here are the measurements:
14 s – reset (note that's 14 seconds including clicking away a UAC prompt)
80 s – bar is at the finish but doesn't reset
94 s – installation finished