Bug 51526 - Cannot install 3.6 beta2, ure and uno-libs3 have circular dependencies
Summary: Cannot install 3.6 beta2, ure and uno-libs3 have circular dependencies
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 09:28 UTC by Yotam Benshalom
Modified: 2012-06-29 05:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yotam Benshalom 2012-06-28 09:28:20 UTC
Problem description: 
On ubuntu 12.04, libreoffice 3.6 beta 2 is not installable because the packages ure and uno-libs3 depend on each other.

Steps to reproduce:
1. Remove all libreoffice packages.
2. Type in terminal: sudo apt-get install ure
3. Type in terminal: sudo apt-get install uno-libs

Current behavior:
You will receive the following error messages:
1. ure : Depends: uno-libs3 (= 3.6.0~beta2-0ubuntu1~ppa1~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

2. uno-libs3 : Depends: ure (>= 3.6.0.0.beta2~) but 3.6.0~beta2-0ubuntu1~ppa1~precise1 is to be installed
E: Unable to correct problems, you have held broken packages.

Expected behavior:
These packages should install fine. The current situation blocks the entire libreoffice from installing.


Platform (if different from the browser): ubuntu 12.04, 64 bit
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20120628 Firefox/15.0a2
Comment 1 Yotam Benshalom 2012-06-28 09:53:08 UTC
The installation attempt was done using this ppa:
https://launchpad.net/~libreoffice/+archive/libreoffice-prereleases/
Comment 2 Björn Michaelsen 2012-06-29 05:42:38 UTC
Not a LibreOffice upstream bug. Should be fixed now, thanks to fixes by Rene Engelhard.