Bug Hunting Session
Bug 51569 - ASKLIBREOFFICE Button to select "best answer" is missing
Summary: ASKLIBREOFFICE Button to select "best answer" is missing
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: high critical
Assignee: Alexander Werner
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-29 10:26 UTC by Robinson Tryon (qubit)
Modified: 2012-07-25 15:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2012-06-29 10:26:02 UTC
I'm not currently able to select the "best answer" for any question I've posted on the Ask.LO site as I can't find the button in the web interface.

I posted the following question and got confirmation from another user that the select button was missing:
http://ask.libreoffice.org/question/3617/how-do-i-mark-the-best-answer-to-my-question-on/

@tohuwawohu wrote:

---
This site had a short downtime last weekend to update the askbot software (should fix the upload images bug, but didn't sadly). Since that downtime, the button to "accept" an answer has disappeared.
---

This seems like a pretty bad bug, as it blocks the fundamental workflow of the site and frustrates every new user who tries to follow instructions and mark their questions as correctly answered. Given the disruption this bug causes, I'm setting severity to 'critical'; feel free to triage into a new category as appropriate.
Comment 1 manj_k 2012-06-29 13:22:02 UTC
Confirmed.
Comment 2 Christian Lohmaier 2012-06-30 03:16:50 UTC
Hi Alex, any idea what's wrong?

The button's html is rendered to the page, but the corresponding css to render it seems to be gone?
i.e.
 <div id="answer-img-accept-920" class="answer-img-accept" title="mark this answer as correct (click again to undo)"></div>

is in the html, but there is no style for answer-img-accept, thus the button is invisible.

Only the hover one is present:
.question-page .answer-img-accept:hover{background:url(../images/vote-accepted-on.png);}


the file in askbot/skins/... has the correct stlyes, but the one in static doesn't.

but as the size is rather different, I refrain from just copying them over. There likely is some compression/whitespace removal stuff done when properly syncing the contents.

$ wc askbot/skins/default/media/style/style.css static/default/media/style/style.css 
  3604   8755  78840 askbot/skins/default/media/style/style.css
   527   1880  52572 static/default/media/style/style.css
Comment 3 beimaginativeegroup 2012-07-10 12:31:42 UTC
I've added this to the Website/Tasks wiki page, please when fixed cut it out so that we keep the wiki up-to-date.
Comment 4 Robinson Tryon (qubit) 2012-07-10 18:14:24 UTC
(In reply to comment #3)
> I've added this to the Website/Tasks wiki page, please when fixed cut it out so
> that we keep the wiki up-to-date.

http://wiki.documentfoundation.org/Website/Tasks

What purpose does the Tasks page serve? It looks just like a shortlist of some website-related bugs. Right now it's an Orphan page, so people will have to know it exists and go looking for it. If there's any way for us automate the maintenance of that page, that would be much preferable to us having to do manual updates.
Comment 5 beimaginativeegroup 2012-07-12 09:15:41 UTC
I'll send this to the mailing list to see if there's way to automatically update tasks. However, the list is becoming taller.
Comment 6 Alexander Werner 2012-07-25 09:42:15 UTC
Fixed an error in the merge from upstream askbot, updated the settings.py (corrected source and target static files directories), and collected static files.
Button is visible again.
Comment 7 manj_k 2012-07-25 09:44:40 UTC
Thanks – VERIFIED.
Comment 8 Robinson Tryon (qubit) 2012-07-25 15:00:03 UTC
looks good