Download it now!
Bug 51759 - terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'
Summary: terminate called after throwing an instance of 'com::sun::star::uno::Deployme...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: All Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-07-05 12:08 UTC by OfficeUser
Modified: 2012-07-26 19:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot lodev3.6 Draw (195.18 KB, image/png)
2012-07-08 10:50 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2012-07-05 12:08:09 UTC
OS = Ubuntu

Can open blank application without any document loaded. Trying to start any Libo application either does nothing, hangs or closes LibO framework!
Comment 1 Florian Reisinger 2012-07-06 01:25:52 UTC
Can't repoduce this....

Can you please clear your user profile...
Comment 2 Florian Reisinger 2012-07-06 01:29:25 UTC
Ok, CRAH when opening .xlsx NOT .docx
.fodt .odt is OK

More research needed
Comment 3 Cor Nouws 2012-07-06 01:43:06 UTC
Irregularly I have a problem when I open a spreadsheet, that at the first attempt the office crashes: "property not found"
(haven't found time yet to investigate, maybe already known ?)
Comment 4 OfficeUser 2012-07-08 10:50:20 UTC
More precise description:

- I start "lodev3.6": The GUI is loaded as excepted displaying the dialogue with the application buttons.

- If I start the Draw application - for example - LibO freezes with the display in the attached screen shot.
Comment 5 OfficeUser 2012-07-08 10:50:48 UTC
Created attachment 63977 [details]
screenshot lodev3.6 Draw
Comment 6 OfficeUser 2012-07-08 10:51:32 UTC
typo:
excepted -> expected
Comment 7 OfficeUser 2012-07-09 19:07:28 UTC
Bug also present in:

Version 3.6.0.0.beta3 (Build ID: 3e2b862)
Comment 8 OfficeUser 2012-07-09 19:10:22 UTC
- Formula: Framework closes without message

- Draw: Freeze

- Presentation: Freeze

- Calc: Framework closes without message

- Writer: Nothing happens when clicking button
Comment 9 OfficeUser 2012-07-09 19:11:58 UTC
I'm not able to use this build while current "stable" x86_64 builds are running without problems on my machine.
Comment 10 OfficeUser 2012-07-14 18:33:52 UTC
Is someone working on this bug? Is additional info necessary?
Comment 11 Cor Nouws 2012-07-14 22:24:01 UTC
Did you try with a fresh user profile?
Comment 12 OfficeUser 2012-07-15 09:31:45 UTC
Not sure. I have not deleted profile of stable builds. But I thought beta builds would use separate profile directory.

Could you tell me please where stable and beta builds store their profiles? I cannot find a directory ".libreoffice" in home direoctory.
Comment 13 OfficeUser 2012-07-16 21:11:45 UTC
I have deleted all LibO stuff in opt and .config (profiles) and did a CLEAN install of Version 3.6.0.1 (Build ID: 73f9fb6)

LibO_3.6.0.1_Linux_x86-64_install-deb_en-US.tar.gz
LibO_3.6.0.1_Linux_x86-64_langpack-deb_de.tar.gz
LibO_3.6.0.1_Linux_x86-64_helppack-deb_de.tar.gz

==> Same problem! :-((


Why do we release "Release Candidates" while there are such blockers?
Comment 14 OfficeUser 2012-07-17 11:34:15 UTC
Related to the following issue?
https://bugs.freedesktop.org/show_bug.cgi?id=52017
Comment 15 OfficeUser 2012-07-18 19:23:29 UTC
No I can give a little bit more information.

I found another way which forces a close of LibO. If I try to open the Options from within a blank GUI, LibO quits with the following message in the terminal:

terminate called after throwing an instance of 'com::sun::star::uno::DeploymentException'


(Changed platform to "All" since I'm not sure if this is a x86-64 only problem.)
Comment 17 OfficeUser 2012-07-18 19:44:30 UTC
I found that Base is the only working application.

Could this bug be Java related? Is the base the only application not using Java?
Comment 18 OfficeUser 2012-07-20 21:23:50 UTC
My installation is also affected by this bug:
https://bugs.freedesktop.org/show_bug.cgi?id=51659

Related?
Comment 19 Petr Mladek 2012-07-25 08:53:20 UTC
OfficeUser, do you use the official TDF packages from http://www.libreoffice.org/download/pre-releases/ or the Ubuntu-specific builds?

Also, could you please attach strace and backtrace logs?

The backtrace log is a bit tricky because it does not crash => you need to break the cycle by [Ctrl-c] when it freezes. Please, do not forget to get backtrace from all threads (thread apply all bt).

Anyway, many other people are able to run the official Linux packages => it is somehow specific => it can't block the release for others => reducing the severity.
Comment 21 OfficeUser 2012-07-26 19:44:12 UTC
Fixed in
Version 3.6.0.2 (Build ID: 815c576)