Bug 51878 - [XLS] FILESAVE recent changes around 'DefaultRowHeight' plays too bad in some cases
Summary: [XLS] FILESAVE recent changes around 'DefaultRowHeight' plays too bad in some...
Status: RESOLVED DUPLICATE of bug 50304
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 51200 52141 52211 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-08 23:33 UTC by Valek Filippov
Modified: 2013-06-29 13:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
File to reproduce the problem (13.50 KB, application/msexcel)
2012-07-08 23:33 UTC, Valek Filippov
Details
one more test file (32.00 KB, application/msexcel)
2012-07-26 12:21 UTC, Valek Filippov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valek Filippov 2012-07-08 23:33:46 UTC
Created attachment 63989 [details]
File to reproduce the problem

Resave attached file (~13Kb) as XLS from LO Calc 3.5.5 or newer (including 3.6beta2). Result would be ~1.3Mb.

Original file has reduced heights for all rows after row 42.
In original XLS it's stored as 'DefaultRowHeight' record and a few 'row' records for non-empty rows (some of the first 42).

LO Calc saves it with different value for 'DefaultRowHeight' and million of 'row' records.

LO Calc 3.5.3 saves it without this problem.

Workaround: change height of all non-used rows to default one.

"<moggi> http://cgit.freedesktop.org/libreoffice/core/commit/sc?h=libreoffice-3-5-5&id=c9749c917e67a70a0cb283e180fd1c05f0cf3c2a"
Comment 1 Valek Filippov 2012-07-13 01:54:30 UTC
52029 could be related to this one.
Comment 2 Markus Mohrhard 2012-07-16 13:00:01 UTC
*** Bug 51200 has been marked as a duplicate of this bug. ***
Comment 3 Markus Mohrhard 2012-07-16 14:07:08 UTC
*** Bug 52141 has been marked as a duplicate of this bug. ***
Comment 4 Markus Mohrhard 2012-07-17 04:39:53 UTC
Should be fixed for 3.6.0 RC2 by reverting the problematic commit.

@Noel Could you please have a look at this problem? We did not yet revert it for 3-5
Comment 5 vitriol 2012-07-17 21:11:25 UTC
*** Bug 52211 has been marked as a duplicate of this bug. ***
Comment 6 Roman Eisele 2012-07-18 19:32:26 UTC
NEW due to all the duplicates and Markus Mohrhard's comments.
Comment 8 Brian Gregory [UK] 2012-07-24 01:37:46 UTC
I am getting huge XLS files when saving spreadsheets as XLS with spreadsheets
that previously were similar size or slightly smaller in XLS form than in ODS
form.
Now the XLS file is well over 50 times bigger than the ODS file!!!
This is with V 3.5.5.3 on WINDOWS.
Comment 9 Noel Power 2012-07-24 13:01:35 UTC
(In reply to comment #4)
> Should be fixed for 3.6.0 RC2 by reverting the problematic commit.
> 
> @Noel Could you please have a look at this problem? We did not yet revert it
> for 3-5

bah, just back from vacation will start looking :-/
Comment 10 Valek Filippov 2012-07-26 12:21:57 UTC
Created attachment 64725 [details]
one more test file
Comment 11 Noel Power 2012-08-09 14:52:44 UTC
fixed as a result of new patches for bug #50304
Comment 12 Björn Michaelsen 2013-06-26 18:37:28 UTC
Adding downstream bug, also setting version to 3.5.5.2 as per downstream bug description as a regression between 3.5.4 and 3.5.5.
Comment 13 Christopher M. Penalver 2013-06-29 13:07:27 UTC

*** This bug has been marked as a duplicate of bug 50304 ***