Bug 51951 - PDF Import 1.0.5. : Some vectorial elements not imported correctly
Summary: PDF Import 1.0.5. : Some vectorial elements not imported correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: NoRepro:4.1.3.2:OSX10.9 NoRepro:4.3.0...
Keywords:
Depends on: 86211
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-10 14:49 UTC by ZioTibia81
Modified: 2015-12-20 22:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Imported PDF result (10.23 KB, application/vnd.oasis.opendocument.graphics)
2012-07-10 14:49 UTC, ZioTibia81
Details
Original PDF (8.62 KB, application/pdf)
2012-07-10 14:50 UTC, ZioTibia81
Details
Additional comments on wrong import (10.23 KB, application/vnd.oasis.opendocument.graphics)
2013-12-11 13:41 UTC, ZioTibia81
Details
test.pdf (8.22 KB, application/pdf)
2014-07-16 08:40 UTC, ZioTibia81
Details
Result of test.pdf import (16.90 KB, application/vnd.oasis.opendocument.graphics)
2014-07-16 08:48 UTC, ZioTibia81
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ZioTibia81 2012-07-10 14:49:52 UTC
Created attachment 64073 [details]
Imported PDF result

See arrows and text position on attached ODG and original imported PDF
Comment 1 ZioTibia81 2012-07-10 14:50:35 UTC
Created attachment 64074 [details]
Original PDF
Comment 2 Samuel Mehrbrodt (CIB) 2013-02-16 11:58:55 UTC
Confirmed in version 4.0.0
Comment 3 retired 2013-12-11 13:20:19 UTC
WORKSFORME OS X 10.9 LO 4.1.3.2 + 4.3.0.0alpha0+.
Comment 4 ZioTibia81 2013-12-11 13:40:41 UTC
Not resolved on 4.1.3.2 Win32
See comment on today attachment.
Comment 5 ZioTibia81 2013-12-11 13:41:43 UTC
Created attachment 90607 [details]
Additional comments on wrong import
Comment 6 ZioTibia81 2014-07-16 08:40:52 UTC
Created attachment 102905 [details]
test.pdf
Comment 7 ZioTibia81 2014-07-16 08:48:46 UTC
Created attachment 102906 [details]
Result of test.pdf import

This is the result importing test.pdf (LibreOffice 4.2.5.2 win32)

- Text is in wrong position
- Continous black lines converted in spotted lines
- Arrows converted in two triangles and a square (The items circled were not imported but manually entered to show the anomaly in the arrows)
Comment 8 vvort 2014-09-14 10:08:30 UTC
Tested with dev build v4.4.0.0.alpha0+
(f39ed4c680fe8ef2ea3f0ace91ea3175551ec9c5):

Text position problems: fixed
Spotted lines: fixed
Black rect around arrows: fixed

Which left unfixed is rectangular fill of arrows
(because there is no masking support in LO)

4.3 build seems to have most of this problems fixed too
Comment 9 ZioTibia81 2014-09-15 08:41:27 UTC
I confirm that on 4.3.1.2 al fixed except rectangular fill of arrows.
Comment 10 Joel Madero 2014-11-05 03:31:14 UTC
No evidence that this was confirmed by QA team - moving to UNCONFIRMED. Thanks for your understanding.
Comment 11 Robinson Tryon (qubit) 2014-11-11 22:08:00 UTC
(In reply to ZioTibia81 from comment #9)
> I confirm that on 4.3.1.2 al fixed except rectangular fill of arrows.

CONFIRMED on LO 4.4.0.0.alpha2 + Ubuntu 14.04

Arrowheads do have weird rectangular-box-fill overlaid them.

Status -> NEW
Comment 12 vvort 2014-11-12 16:16:35 UTC
Bug 86211 contains fix for arrowhead problem
Comment 13 QA Administrators 2015-12-20 16:16:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 14 ZioTibia81 2015-12-20 21:26:51 UTC
Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: it-IT (it_IT)

All fixex except Arrowheads do have weird rectangular-box-fill overlaid them.
Comment 15 Joel Madero 2015-12-20 22:17:45 UTC
I think you should report that separately as it's a very specific sub-set of this bug. Closing as WFM - if you could open that other bug and CC me on it that would be fantastic. Thanks