Download it now!
Bug 52006 - FILEOPEN: can't open file with two leading slashes
Summary: FILEOPEN: can't open file with two leading slashes
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Blocks: File-Opening
  Show dependency treegraph
Reported: 2012-07-12 10:14 UTC by muzzol
Modified: 2018-11-13 03:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description muzzol 2012-07-12 10:14:52 UTC
Problem description: 

I mount some resources via samba (smbnetfs) and it seems that samba sometime adds an additional slash.

libreoffice can't open any file that has two leading slashes.

Steps to reproduce:
1. Copy a simple .odt file to /tmp/test.odt
2. execute: libreoffice '/tmp/test.odt'

it should open normally. close it and now try with

3. libreoffice '//tmp/test.odt'

Current behavior: file is not opened

Expected behavior: file is opened

Platform (if different from the browser): 
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0.1
Comment 1 Urmas 2012-07-12 13:08:21 UTC
Same problem in Windows too.
Comment 2 tommy27 2014-12-13 09:46:16 UTC
is issue still present in LibO
Comment 3 Douglas Vigliazzi 2015-04-27 15:19:30 UTC
This issue still present in LibO 4.3.7
Comment 4 QA Administrators 2016-09-20 09:32:51 UTC Comment hidden (obsolete)
Comment 5 muzzol 2016-10-11 08:08:04 UTC
bug is still here

$ libreoffice --help
LibreOffice 420m0(Build:2)

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.5 LTS
Release:	14.04
Codename:	trusty
Comment 6 tommy27 2016-10-11 08:31:47 UTC
LibO is an obsolete (even jurassic) release.
you should retest with latest stable branch which is 5.1.5
thousands of bugs have been fixed since 4.2.x
Comment 7 muzzol 2016-10-11 09:47:59 UTC
you're right, I'm at work and I've tested with an old machine.

Just tested on a fresh instal with two different versions and still not working. Fist one is from regular ubuntu packages, 5.2.* is from PPA

Have you tried? this bug is really easy to reproduce.

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.1 LTS
Release:	16.04
Codename:	xenial

$ libreoffice --help
LibreOffice 10m0(Build:2)

$ libreoffice --help
LibreOffice 20m0(Build:2)
Comment 8 QA Administrators 2018-11-13 03:41:42 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat:

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team