Bug Hunting Session
Bug 52071 - FILEOPEN: The Greek codepage in styles of a DOC (Word-6) file
Summary: FILEOPEN: The Greek codepage in styles of a DOC (Word-6) file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks:
 
Reported: 2012-07-13 19:39 UTC by ape
Modified: 2015-12-15 11:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
gif-animation and RTF files (111.98 KB, application/zip)
2012-07-13 19:39 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2012-07-13 19:39:50 UTC
Created attachment 64189 [details]
gif-animation and RTF files

LibreOffice-3.5.5;3.6.0.1
OS: Windows_XP_64-bit; Lubuntu-12.04_64-bit
 The Greek codepage in styles of a RTF file.
Files are created MS_Word-97(95)_RUS in MS_Windows-98(95OCR2 or NT-4)_RUS. 
Reproduction (see gif-animation into the attachment):
1. Open a file.
2. Press a window "Styles" (a toolbar Formatting).
The styles used in the document are displayed in the Greek coding. If the file has been saved as "*.odt" and was reloaded, then styles of a new file are kept also in the Greek codepage.
I observe a bug in files in which there are paragraphs (style, differs from "default" or "text_body") is higher than the Heading paragraph. These paragraphs are perceived by the filter of export as the "Header (Default)".
If these paragraphs of files are perceived as the "Header (1-st page)", then the style of these paragraphs has a Russian codepage.
As I remember, I did not use the Header in initial files.
Content of the attachment: gif-animation; the Greek CP file; the Russian CP file.
Comment 1 Urmas 2012-07-14 07:41:58 UTC
How the f..l is that Greek? Had you forgot physics lessons from 6th grade?

Still, RTF support in LO is completely broken. DON'T USE IT.
Comment 2 Valek Filippov 2012-07-14 11:34:02 UTC
vmiklos,
in 'Russian_Header-1st_page.RTF' the only image also seems to be scrambled.

Styles encoding is ok for me in that file on linux (LO 3.5.3 and LO 3.6b2).
Styles encoding is wrong for the same versions with 'Greek_Header-default.RTF'.

'Greek_Header-default.RTF' is actually a DOC file.
Comment 3 ape 2012-07-15 16:13:37 UTC
(In reply to comment #2)
> vmiklos,
> in 'Russian_Header-1st_page.RTF' the only image also seems to be scrambled.
> 
> Styles encoding is ok for me in that file on linux (LO 3.5.3 and LO 3.6b2).
> Styles encoding is wrong for the same versions with 'Greek_Header-default.RTF'.
> 
> 'Greek_Header-default.RTF' is actually a DOC file.

Excuse, I was mistaken in 1-st message. This mistake in the name of styles is in text documents "Word6". The file "Greek_Header-default.RTF" has wrong expansion and should have the name "Greek_Header-default.DOC".
Comment 4 Miklos Vajna 2012-08-01 11:22:13 UTC
Valek,

Yes, once again two file with two independent problems within a single bugreport. :-)

So given that the title says it's a Word-6 file, let's track the style name encoding problem here. I can reproduce it, but not really familiar with the WW6 import code, so not assigning to myself. (I checked if it's a regression, but seems this was already bad with OOo 3.3.)

The image in the RTF file is actually a set of lots of small images. Please, let's deal with that in a separate bug, then I'll try to have a look.

Miklos
Comment 5 ape 2012-08-03 09:48:54 UTC
(In reply to comment #4)
> Valek,
> 
> Yes, once again two file with two independent problems within a single
> bugreport. :-)
> 
> So given that the title says it's a Word-6 file, let's track the style name
> encoding problem here. I can reproduce it, but not really familiar with the WW6
> import code, so not assigning to myself. (I checked if it's a regression, but
> seems this was already bad with OOo 3.3.)
> 
> The image in the RTF file is actually a set of lots of small images. Please,
> let's deal with that in a separate bug, then I'll try to have a look.
> 
> Miklos

Miklos,
Bug 52160 has been created.
Comment 6 ape 2012-12-29 08:25:33 UTC
Miklos, this is the nice job!
I did not find this bug in the program 'LOdev 4.0.0.0.beta2+ (Build ID: c5229f497008051b078e9f76e00031dfb3b6f41; Date: 27 december 2012)'.
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:00:14 UTC
Migrating Whiteboard tags to Keywords: (rtf_filter -> filter:rtf)
[NinjaEdit]