Bug Hunting Session
Bug 52080 - Large files become unresponsive since version 3.5.0
Summary: Large files become unresponsive since version 3.5.0
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: x86-64 (AMD64) All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: (target:4.0.0.0.beta1)
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-07-14 12:27 UTC by David
Modified: 2012-12-08 18:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
large sample document (804.67 KB, application/vnd.oasis.opendocument.text)
2012-07-14 12:27 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-07-14 12:27:08 UTC
Created attachment 64199 [details]
large sample document

I have confirmed that this bug is still not fixed on version 3.6.0 RC1.  To
make the failure occur, open the test-bug345.odt file attached to this thread
for editing (this is the same file used in bug 48932), scroll up & down in the document for 5 or 10 seconds and then randomly select any text.  I have a 3ghz quad core computer and the application freezes on me and is unresponsive for 3 minutes before I can once again do any editing.  As soon as I try to select any text again it again becomes unresponsive for another 3 minutes.  On Windows XP it will seem to be working for a while and then the program will totally crash.  I am still unable to upgrade from 3.4.6 because of this regression.
Comment 1 Rainer Bielefeld Retired 2012-07-15 07:32:20 UTC
Fix for "Bug 48932 - EDITING: Writer 3.5.2 slow typing in large documents" did not solve user's problem.

More or less [Reproducible] with reporter's sample and Server Installation of  "LibreOffice 3.6.0.1 rc  German UI/Locale [Build-ID: 73f9fb6] on German WIN7 Home Premium (64bit). After small edits (delete first character) LibO stops responding for several seconds or minutes, sometimes even crashes with WIN error message. 

Because this one is reported as a 3.6 problem for hangs, I submitted "Bug 52108 - CRASH on any action for particular big .odt" for a CRASH problem, but I am pretty sure that that one has the same roots like this bug.

No problem with 3.4.5

@David
<https://wiki.documentfoundation.org/QA-FAQ#How_to_use_attached_sample_documents_for_multiple_Bug_Reports>
Comment 2 Roman Eisele 2012-07-15 15:56:31 UTC
Partially REPRODUCIBLE also on MacOS X 10.6.8 (Intel) with
* LibreOffice 3.5.5.3 (Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21)
* LibreOffice 3.6.0.1 (Build ID: 73f9fb6)
both with German langpakc installed, and reporter's sample file.

I don't see any crashes, at least for now, but, as Rainer wrote: "After small edits (delete first character) LibO stops responding for several seconds or minutes". I can confirm this.
Comment 3 Aibara 2012-08-20 18:35:53 UTC
I can confirm the freezing once a large file is opened. Using version 3.6.0.2 (Build ID: 360m1(Build:102)) on Ubuntu 12.04. Version 3.5 actually worked ok for me, save for freezing when I went to save a file. Now Writer is unresponsive for almost a minute soon after I open a large file or being editing it.
Comment 4 Aibara 2012-08-20 19:04:19 UTC
I should also add that this even happens with much smaller documents than the sample attached above (e.g. 500+ pages).
Comment 5 David 2012-08-23 21:42:44 UTC
Aibar wrote,
"I should also add that this even happens with much smaller documents than the
sample attached above (e.g. 500+ pages)."

It may have something to do with the complexity of the document.  I have
documents that have far less pages but have many paragraph and character style
changes along with many footnotes which do not work with version 3.5 or
greater. But I also have much larger documents with very few footnotes or style changes which work fine.
Comment 6 Aibara 2012-08-28 17:42:28 UTC
The problems occur when I simply copy the same text over and over to make a large document, so even very simple documents are affected here. Regardless, LibreOffice 3.4 and before handled all these large files just fine, so there's some sort of regression here.


(In reply to comment #5)
> It may have something to do with the complexity of the document.  I have
> documents that have far less pages but have many paragraph and character style
> changes along with many footnotes which do not work with version 3.5 or
> greater. But I also have much larger documents with very few footnotes or style
> changes which work fine.
Comment 7 Sebastian@SSpaeth.de 2012-09-03 09:02:16 UTC
(In reply to comment #5)
> It may have something to do with the complexity of the document.  I have
> documents that have far less pages but have many paragraph and character style
> changes along with many footnotes which do not work with version 3.5 or
> greater.

This would be bug 38513
Comment 8 Aibara 2012-10-18 23:49:29 UTC
The regression is still present in 3.6.2.2 (using Ubuntu 12.10). As a large file begins to be edited, LibreOffice Writer freezes totally (including other open windows), for over a minute. Just had someone complain to me that they thought their file was corrupted or something, since they had forced quit the program since it was hanging for so long. But no, it was just a big file and LibreOffice 3.6.
Comment 9 Michael Meeks 2012-12-07 14:57:00 UTC
I'm struggling to reproduce this on Linux with the 4.0.0 builds - I can select-all and do the word-count for that selection in ~3 seconds - which is reasonable. I can delete characters one by one from the start.

I tried doing random edits across the place - and it generall seems reasonably responsive - I've certainly not managed to provoke any length of hang more than a second or so.

Of course, if I copy/paste the entire 1/2 million word document a few times I get a biiig hang; but I'm expecting that I suppose ;-) what operations are other people doing ?

Thanks !
Comment 10 David 2012-12-07 20:13:41 UTC
I have not tried build 4.0.0 but I have noticed improvements.  As of 3.6.3 the application became unresponsive for only about 20 seconds at a time instead of minutes.  I did a minimal amount of testing on Windows XP and it seem to behave exactly the same there also and I had no crashes in XP like I did before.  In version 3.6.4 the unresponsiveness is only noticed on the second edit or when selecting text.  To test, open the sample document, type a letter somewhere within the document. It will behave normally. Then type another character and it's about a 10 or 20 second wait.  After that the application behaves normally when typing so that is a huge improvement.  

But, the other situation that produces unresponsive behavior is when selecting text.  The sample document attached to this thread appears to behave differently in this regard than the other large documents I have.  In the sample document double-click on any word and it takes about 10 seconds on a 3GHz Quad-core processer to become responsive again.  This is really still unacceptable.  Now on the documents I need to use I've found the situation to be a little different.  The first time I double-click to select a word there might be a couple second delay than it starts responding more quickly after that. I have noticed though, a slight delay (half-second?) when selecting a word then typing a new one. But it is certainly usable at this point.  Then after a period of time (might be hours), I've noticed that after selecting some text it will become unusably slow again.  I have no idea what is happening in the software but it seems like some sort of buffer is getting filled and then it is no longer responsive like it was and the file needs to be closed and re-opened.  For this situation I think the sample document is the best test case to use since every time text is selected it becomes unresponsive for too long for it to be usable.
Comment 11 David 2012-12-08 00:04:32 UTC
I've just tested it with 4.0.0 beta 1.  It looks like the delay when making the second edit has disappeared.  The only problem I see now is with the delay when selecting text in the sample document.
Comment 12 David 2012-12-08 00:12:13 UTC
I also notice with 4.0.0 that I get the same delay when scrolling back & forth in the document or when zooming in or out.  It's only about a 7 or 8 second delay on my computer but that still makes it rather unusable since scrolling is often a frequent task.
Comment 13 David 2012-12-08 00:24:19 UTC
I should note that the delay when zooming or scrolling in a large document is a regression from 3.6.4.
Comment 14 Rainer Bielefeld Retired 2012-12-08 18:45:21 UTC
WFM due to latest comments

For the remaining performance problems separate bugs should be reported so that the bugs can be fixed one by one.

@David
Can you confirm "Bug 58029 - EDITING: Selecting words in very large documents needs too much time"?