Bug Hunting Session
Bug 52133 - Different View States for different sheets of a Calc Spreadsheet
Summary: Different View States for different sheets of a Calc Spreadsheet
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 117316 (view as bug list)
Depends on:
Blocks: Calc-Page-Break
  Show dependency treegraph
 
Reported: 2012-07-16 07:01 UTC by Vijay Matange
Modified: 2018-04-30 17:35 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vijay Matange 2012-07-16 07:01:13 UTC
Libre Office 3.5.4.2: Calc on Windows 7, 64bit

Let us assume there are more than two sheets in a spreadsheet. Presently it is not possible to have separate View States for each sheet.

For eg. if Sheet1 is set to View>Normal, then Sheet2 cannot be set to View>Page Break Preview independently of Sheet1.  If Sheet2 is set to Page Break Preview then Sheet1 also gets set to Page Break Preview and so on.

Earlier even zoom levels were not discrete, but that was solved by the Tools>Options>LibreOffice Calc>View>Zoom>Synchronize sheets check-box.  

Something similar if added somewhere will help a lot, for those files where only some of the sheets are used for printing and the other sheets are kept for calculation and data entry.
Comment 1 Yousuf Philips (jay) (retired) 2016-09-17 18:53:41 UTC
Document view modes are document level setting and not a page/sheet/slide level feature. Doubt such a feature is available in any other office suite or even in the odf format, but lets see.
Comment 2 Heiko Tietze 2016-09-18 09:04:48 UTC
Agree with Jay and close as WONTFIX.
Comment 3 Thomas Lendo 2018-04-30 17:31:53 UTC
*** Bug 117316 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Lendo 2018-04-30 17:35:14 UTC
@Regina: Is this enhancement request possible in ODF format?