Download it now!
Bug 52156 - error ORA-00933 : Sql command not properly ended
Summary: error ORA-00933 : Sql command not properly ended
Status: RESOLVED DUPLICATE of bug 81213
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-16 15:39 UTC by Roberto Barraco
Modified: 2015-05-03 14:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Barraco 2012-07-16 15:39:09 UTC
Hi 
I am a newbie of LibreOffice but I often use  MSACCESS. I have started drwawing a query using "Query Design". My goal is to query an Oracle Table via JDBC. The conenction is up . After I push the F5 button I receive the mentioned error. The information about the SQL statemen show this :

SELECT "FORNITORE", "RAPPORTI" FROM "SIDATI"."FORNITORI" AS "FORNITORI"

I've tried SQL directly and seems that Oracle doesn't like 'AS "FORNITORI"'. IF I erase these words the F5 works fine.
Any help will be accepted
Comment 1 Robinson Tryon (qubit) 2014-11-14 22:45:12 UTC
(In reply to Roberto Barraco from comment #0)
> Hi 
> I am a newbie of LibreOffice but I often use  MSACCESS. I have started
> drwawing a query using "Query Design". My goal is to query an Oracle Table
> via JDBC. The conenction is up . After I push the F5 button I receive the
> mentioned error. The information about the SQL statemen show this :
> 
> SELECT "FORNITORE", "RAPPORTI" FROM "SIDATI"."FORNITORI" AS "FORNITORI"
> 
> I've tried SQL directly and seems that Oracle doesn't like 'AS "FORNITORI"'.
> IF I erase these words the F5 works fine.
> Any help will be accepted

Hi Roberto,
Did you ever get this problem sorted out?  Can you still reproduce the problem using modern (4.3-era) builds of LibreOffice?

(After you comment, please change the status back to UNCONFIRMED. Thanks!)

Status -> NEEDINFO
Comment 2 Alex Thurgood 2015-01-03 17:41:26 UTC
Adding self to CC if not already on
Comment 3 Robert Großkopf 2015-05-03 14:34:55 UTC
Have a look here:
https://bugs.documentfoundation.org/show_bug.cgi?id=81213

It has been the same reason and had been fixed already.
I will close this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 81213 ***