Download it now!
Bug 52495 - 3.6 (RC2) Runtime Error, Fatal
Summary: 3.6 (RC2) Runtime Error, Fatal
Status: RESOLVED DUPLICATE of bug 51252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-25 16:55 UTC by Scott M. Sanders
Modified: 2012-07-26 13:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott M. Sanders 2012-07-25 16:55:55 UTC
I ran 3.6 RC2 once. Now it always crashes with

"Microsoft Visual C++ Runtime Library
Runtime Error!
Program: C:\Program Files (x86)\LibreOffice 3.6\program\soffice.bin
This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."

This happened after I installed the following extensions...
- addpics-2.4.oxt
- copyvisicells-1.0.3.oxt
- GallerySignauxDangers.1.0.4.oxt
...and attempting to install these OpenOffice.org extensions which failed...
- oracle-pdfimport.oxt
- mysql-connector-ooo-1.0.1-windows-intel.oxt

The Oracle PDF Import extension had some error that it already existed and a long Java-looking class in the error. The Runtime error began after that, while 3.6 was still open.

I would think that LibreOffice would warn me if an extension is not compatible, but it did not.

Now I cannot open 3.6 at all, even after repairing, modifying, and uninstalling and reinstalling it.
Comment 1 Scott M. Sanders 2012-07-25 19:12:11 UTC
I resolved this by manually removing C:\Users\ssanders\AppData\Roaming\LibreOffice which I think LibO uninstall should have removed.
Comment 2 Scott M. Sanders 2012-07-25 19:59:31 UTC
Related probably: https://bugs.freedesktop.org/show_bug.cgi?id=52497
Comment 3 Stephan Bergmann 2012-07-26 13:54:51 UTC
(In reply to comment #1)
> I resolved this by manually removing
> C:\Users\ssanders\AppData\Roaming\LibreOffice which I think LibO uninstall
> should have removed.

Once a fix for bug 51252 is available, it should have been sufficient to just remove LibreOffice\3\user\extensions, see <https://bugs.freedesktop.org/show_bug.cgi?id=51252#c35>.

*** This bug has been marked as a duplicate of bug 51252 ***