Download it now!
Bug 52523 - MAILMERGE from print menu: Messed up elements (footers, tables, graphics)
Summary: MAILMERGE from print menu: Messed up elements (footers, tables, graphics)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 52542 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-26 08:51 UTC by zap
Modified: 2015-03-25 17:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example producing messed up mail merge outputs (on current LO/OOs only) (60.43 KB, application/vnd.oasis.opendocument.text)
2012-07-26 08:51 UTC, zap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zap 2012-07-26 08:51:53 UTC
Created attachment 64703 [details]
Example producing messed up mail merge outputs (on current LO/OOs only)

I hope somebody will read this long post. But obviously something mysterious happened to LO/OO after v3.2.

I consider all this a candidate for the "most annoying bug". 

I am preparing a rather complex mail letter with switching page forms (first page to standard) and backgrounds (vector drawings from Impress, linked via header), cr code and photo graphics, tables, one rotated text box and of course database fields, conditional output and so forth.
I'm familiar with these things and their problems, being an early DOS-Starwriter user (yes, even with paid licenses back in the days).

Surprisingly all of the data features worked when I started a first run with a filled database, but the output was a complete mess though:
On some (not all) pages of the generated mail letters (4 pages each) footers were dropped (including page numbers), on the first letter (or data set) some (not all) graphics were gone, on the next letter they reappeared. From some page on tables were shrunk: their text contents -no variables- were gone. Boxes moved to the wrong page. Nearly everything was affected.
 
First I thought this had to do with the pdf export, but paper prints were messed up the same way.

Then I removed "suspicious" features one by one, but that also didn't help. The remaining elements were still corrupted, I couldn't isolate a single "critical" element.

That led me to the idea that something more general could be buggy and I started to test other/former versions and this approach was successful:
LibreOffice Portable 3.5.5: buggy output
Apache OpenOffice Portable 3.4: buggy output
OpenOffice Portable 3.0: EVERYTHING PERFECT (okay, some impress issues, because of the newer graphic source, but nothing lost during the merge process)
OpenOffice Portable 3.2: EVERYTHING PERFECT (...)
All these are portable versions (Apache is from a different source - winpenpack vs portableapps) I could find, but from the results it's obvious that the problems don't have to do with portable or not.

The fact is that somewhere later than OO 3.2 the code (maybe of the mail merge component) must have been changed (in both forks) and seems to be pretty capricious now.

Attached there's an example file, which is stripped to the basics and one field linked to the default "biblio" database, but it may be linked to any database.

If you print this as mail merge you will see all of the effects I mentioned above.
Remember - all these strange things won't happen in versions up to 3.2!
In my original file single prints are flawless. 

BUT: Interestingly only this example file will also show another strange effect in ALL versions:  
If you run single prints the last pages will be ROTATED (which is not shown in the previews - many of the other problems do).

Maybe this is a key to the whole problem, so I leave it as it is and hope somebody can fix this.
Comment 1 Rainer Bielefeld Retired 2012-07-26 10:16:33 UTC
Good result with printout to FreePDF from Mail Merge Assistant to Addresses from my own Data base 
Good Result with printout from Mail Merge Assistant to Addresses from my own Data base

[Reproducible] with reporter's sample document and mailmerge printout from menu 'File -> Print' with "LibreOffice  3.5.5.3.  German UI/Locale [Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21] on German WIN7 Home Premium (64bit)
 

Steps how to reproduce:
1. Open sample document
2. Menu 'File -> Print'
3. 'Yes' to answer whether you want to print a mail merge letter
4. All further steps to finish a complete mail merge.

Very Damages:
Page 2: Orange picture missing (but visible in further copies)
Page 4: rotated "somebox" missing, also fold marks (also in further copies)
Page 7: Tables very small and without contents (also in further copies)
Page 9: rotated "somebox" on page "Some Invitation" instead of last page of
        letter copy (also in further copies)

and so on

In mail merge letter printed from Mail merge assistant I see some smaller damages:
Page 4: Somebox not rotated in footer, but unrotated in header, fold marks
        at right document margin instead of left margin 
        (also in further copies)



@reporter:
Thank you for your report – unfortunately important information was missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to write more complete Bug reports?

Can you contribute info with what LibO that problem started?
Comment 2 zap 2012-07-27 10:00:57 UTC
Thanks for your quick response,

Your "damage description" is very much according to my observations. One more effect I get is that the footers (including text and pageno.) get lost on some pages.

The (original) text file is brandnew, I never used it on former versions of LibO (some won't install because of Norton Security and dictionary problems).

When I found that the latest AOO was also affected, I stepped back to earlier OO Versions I could find and up to OO3.2 the mail merge was flawless, but I haven't tested later versions...
Comment 3 zap 2012-07-27 10:11:32 UTC
*** Bug 52542 has been marked as a duplicate of this bug. ***
Comment 4 zap 2012-08-08 16:22:30 UTC
Today I tried the first official portable version of LibreOffice (3.3.0.4) and the bug was already there!
The downloads at
downloadarchive.documentfoundation.org/libreoffice/old/
start with v3.3.0.1
So I guess this bug was there from the beginning of LibreOffice.

This bug is VERY annoying, because it produces unpredictible effects in an automatic process. A mail merge is supposed to make things easier, not to produce messed up letters that are send to customers!
My example produces a lot of obvious errors, but I'm convinced that there will be less obvious errors in standard layouts.

Moreover the option to suppress automatically created empty pages is pretty suspicious to me. Why are these pages generated and then need to be suppressed? This doesn't look like clean design.

My example letter has 4 pages.
If I print it with one address selected the print preview counts and shows 4 pages, with some errors already (picture and page number (on page 2) missing).
If I select 2 addresses the print preview counts and shows 7 (!) buggy pages.
If I select 3 addresses the print preview counts and shows 11 (!) buggy pages, page 8 is completely blank.

The new print preview (not the old page preview) is a reliable prediction of the errors to expect.

But maybe it's also the source of these problems (maybe caused by some pre-processing).

I believe this because (OO) versions which don't produce theses errors didn't have this print preview yet! And in ApacheOO there is the same print preview - along with the bugs described here!
Comment 5 Rainer Bielefeld Retired 2012-08-08 17:16:32 UTC
Cáolan:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 6 zap 2012-08-22 15:36:06 UTC
I have a new interesting observation (LO 3.5.5.3):
During mailmerge I chose to print single PDF files (for each data set) - and all of them were okay!
Mailmerging to one big PDF file produced the same mess as printing to a PDF driver or to a real printer.
Again, this points to the direction of an error during some preprocessing which sometimes isn't necessary (e.g. there is no preview in this file print mode)...
Comment 7 zap 2013-03-12 18:35:44 UTC
Same mess up to now:
Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)

I really do think a software named "office" should be able to be used for serious mail merge. Come on, the bug is fully documented and confirmed - where's the problem? Can I be of further help?
Comment 8 Rainer Bielefeld Retired 2013-03-12 18:38:35 UTC
@zap, please consider:
<http://wiki.documentfoundation.org/BugReport_Details#Version>
If you also did this mistake in other Bugs please undo your Version changes there!
Comment 9 Alex Thurgood 2015-01-03 17:38:48 UTC
Adding self to CC if not already on
Comment 10 Jan-Marek Glogowski 2015-03-25 17:17:48 UTC
Version: 4.5.0.0.alpha0+
Build ID: 3dad00879295c04d03f8a5eaeff6794d36ea6d07
Platform: Linux

I downloaded and MM'ed the EXAMPLE.odt.

Selected two records from the "print MM" dialog and saved to disk.

Guess it was fixed in the 4.4 mail merge rework, but didn't try that version.

You can verify with a download from http://dev-builds.libreoffice.org/daily/master/