Bug 52553 - ASKLIBREOFFICE Allowed filetypes for upload too restrictive
Summary: ASKLIBREOFFICE Allowed filetypes for upload too restrictive
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 16:36 UTC by Robinson Tryon (qubit)
Modified: 2014-02-20 16:14 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
MS Word file that appears blank in LibreOffice and can't be uploaded to the AskLibO site (26.50 KB, application/msword)
2012-07-27 18:53 UTC, Hugh Hyatt
Details
MS Word file that appears blank in LibreOffice and can't be uploaded to the AskLibO site (22.00 KB, application/msword)
2012-07-27 18:55 UTC, Hugh Hyatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2012-07-26 16:36:25 UTC
(Per this question:
http://ask.libreoffice.org/question/4203/cant-open-ms-word-documents-after-upgrade-to/)

The allowed upload filetypes (extensions) are: '.jpg', '.jpeg', '.gif', '.bmp', '.png', '.tiff', '.odt', '.ods', '.odp', '.odg', '.odc', '.odf', '.odi', '.odm', '.ott', '.ots', '.otp', '.otg', '.odb'

This list excludes .doc and .zip, two filetypes that would be very useful in helping to triage issues and figure out user problems. The list of filetypes allowed on bugzilla is much more extensive.

Personally, I'd be okay if we adopted a policy of bumping any user-support questions to bugzilla if we need to look at example files, etc. Bugzilla is probably more suited to dealing with this type of user inquiry, however we really would need to make sure that bugreports are dealt with promptly so we encourage users to come back and report bugs/problems in the future.
Comment 1 Hugh Hyatt 2012-07-27 18:53:11 UTC
Created attachment 64799 [details]
MS Word file that appears blank in LibreOffice and can't be uploaded to the AskLibO site
Comment 2 Hugh Hyatt 2012-07-27 18:55:37 UTC
Created attachment 64800 [details]
MS Word file that appears blank in LibreOffice and can't be uploaded to the AskLibO site
Comment 3 Robinson Tryon (qubit) 2012-07-28 13:24:03 UTC
"District Inventory (1).doc" opens fine (correctly?) in LibreOffice 3.4.4 on Ubuntu 11.10. If there is a regression, it looks like it was introduced after that point. I'll run bibisect3.5 and test both files today.
Comment 4 Robinson Tryon (qubit) 2012-07-28 21:14:42 UTC
Testing with bibisect-3.5:

Both Word docs open fine with LibreOffice 3.5.0 Build ID: 85c6244 ("latest"), so moving to bibisect for 3.6.

Testing with bibisect-3.6:

Both Word docs also open fine with LO version 3.6.0alpha0+ (Build ID: 3126fd)("latest").


Absent more testing, the quick short-term solution would be for users to try the 3.6 beta builds (it looks like we're really close to final release, anyhow).
Comment 5 beimaginativeegroup 2012-08-19 16:38:55 UTC
I agree with needing to accept .doc and .docx. If we can't, I think we should make it obvious to the beginner user that he can use Bugzilla. Set as NEW.
Comment 6 Akos Lukacs 2013-02-28 16:18:04 UTC
I agree, that this is too restrictive, especially, that anyone can change the extension, if wants to upload a harmful file.
Just makes posting questions more difficult. 
Please add docx, xlsx, or maybe remove this restiction.
Comment 7 Owen Genat (retired) 2013-08-20 06:10:18 UTC
Just an update on this issue. After the upgrade to Askbot v0.4.78 on 4th July 2013 all file types were excluded from being uploaded and existing attachments no longer appeared linked. On 20th July 2013 I asked this question:

http://ask.libreoffice.org/en/question/20617/question-answer-attachments-for-asklo-not-showing/

...and a day later it was fixed (thanks Evgeny). The list of permissible file types however appears to have been reduced, such that at present this is the message displayed when attempting to upload an ODT:

>allowed file types are '.jpg', '.jpeg', '.gif', '.bmp', '.png', '.tiff'
Comment 8 Owen Genat (retired) 2013-08-20 06:17:21 UTC
Ugh. "Askbot v0.4.78" in my prior comment should of course read "Askbot v0.7.48".
Comment 9 Robinson Tryon (qubit) 2013-10-01 18:32:19 UTC
(In reply to comment #7)
>  The list of permissible
> file types however appears to have been reduced, such that at present this
> is the message displayed when attempting to upload an ODT:
> 
> >allowed file types are '.jpg', '.jpeg', '.gif', '.bmp', '.png', '.tiff'

Hmm, that is a problem. I think that we should restore the previous list:

'.jpg', '.jpeg', '.gif', '.bmp', '.png', '.tiff', '.odt', '.ods', '.odp', '.odg', '.odc', '.odf', '.odi', '.odm', '.ott', '.ots', '.otp', '.otg', '.odb'

We should also add common MS-Office file extensions, as we often field user questions pertaining to specific documents. Here's a quick list:

.doc, .docx, .xls, .xlsx, .ppt, .pptx

And finally, I still think that '.zip' might be helpful. Thoughts?
Comment 10 manj_k 2013-10-01 19:20:30 UTC
(In reply to comment #9, comment #7)

First of all, we should restore the old list (it's much-needed, and the status quo is really annoying).
And (if possible) add the additionally proposed file types too.
Comment 11 m.a.riosv 2013-10-01 20:39:06 UTC
Is there any limitation to restore ODF files?

If not, what we are doing, forbid the use of LibreOffice native files in Ask.LibreOffice.

I am agree with a limit for file size, e.g. 256 Kb or even less, we always have bugzilla for a special case.

But I think it is not a good image, explain such issue every time that is needed attach a file sample. And the time waste for people asking, and for people trying to answer.
Comment 12 Owen Genat (retired) 2013-10-03 00:50:48 UTC
I am in agreement with comment #9 by Qubit. Speaking from an AskLO user/consumer perspective I think this would cover the majority of cases.
Comment 13 manj_k 2014-01-24 11:29:48 UTC
See also: http://nabble.documentfoundation.org/Akbot-uploading-ODF-files-tt4085579.html#a4085581

<quote>
Florian Effenberger: "would be okay for me [...]"
</quote>

@Evgeny
Any objections to the implementation of an enhanced list of permissible file types (with limited file size)?
Comment 14 manj_k 2014-02-20 16:14:58 UTC
Currently allowed file types are:
.jpg · .jpeg · .gif · .bmp · .png · .tiff 
.odt · .ods · .odp · .odg · .odc · .odf · .odi · .odm · .ott · .ots · .otp · .otg .odb
.doc · .docx · .xls · .xlsx · .ppt · .pptx.