Download it now!
Bug 52612 - FILESAVE particular .DOCX (Office Open): Loss of footnotes text
Summary: FILESAVE particular .DOCX (Office Open): Loss of footnotes text
Status: RESOLVED DUPLICATE of bug 52610
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-28 06:21 UTC by ape
Modified: 2013-10-07 21:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
animation.gif (149.90 KB, image/gif)
2012-07-29 10:49 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2012-07-28 06:21:25 UTC
The program "LibreOffice Writer" for all versions, all operating systems.
The file "DOC-export footnote Error.odt" (see attachment_57017; https://bugs.freedesktop.org/attachment.cgi?id=57017) has lost a text of few footnotes when exporting to DOCX-format:
 1. Open the file "DOC-export footnote Error.odt".
 2. File save as a text document "Microsoft Office 2007-2010" - "DOC-export footnote Error.docx" (see attachment_64811; https://bugs.freedesktop.org/attachment.cgi?id=64811).
 3. Reload or reopen the file "DOC-export footnote Error.docx".
 Footnotes of the file "DOC-export footnote Error.docx", beginning with the 59th, completely lost the text. The file "DOC-export_footnote_Error.docx:\word\footnotes.xml" contains the text and ID of all footnotes.
 See also:
Bug_52610 (https://bugs.freedesktop.org/show_bug.cgi?id=52610)
Bug_46020, comment_16 (https://bugs.freedesktop.org/show_bug.cgi?id=46020#c16)
Comment 1 Rainer Bielefeld Retired 2012-07-28 07:05:23 UTC
Attachment 64811 [details] is a rather obscure document with horrible damages from unknwon sources, please see my comment in "Bug 52610 - FILESAVE particular document as .docx (Office Open): Can not be opened with other office software"! I doubt that we should invest manpower here.

@ape:
It would be great if you could create from the scratch an .odt demonstrating the problem. On such a base chance that a developer will accept the Bug is very much bigger.
Comment 2 ape 2012-07-28 09:30:26 UTC
(In reply to comment #1)
> Attachment 64811 [details] is a rather obscure document with horrible damages from
> unknwon sources, please see my comment in "Bug 52610 - FILESAVE particular
> document as .docx (Office Open): Can not be opened with other office software"!
> I doubt that we should invest manpower here.
> 
> @ape:
> It would be great if you could create from the scratch an .odt demonstrating
> the problem. On such a base chance that a developer will accept the Bug is very
> much bigger.

@Rainer Bielefeld: my answer here:
https://bugs.freedesktop.org/show_bug.cgi?id=52610#c2
Comment 3 ape 2012-07-29 10:49:37 UTC
Created attachment 64836 [details]
animation.gif

I hope that animation (see attachment) explains the reason for the disappearance of the text in the footnote with the number> 57. Checked, corrected the file in a text editor.
On the left - "footnotes.xml" file "Bad_LibO.docx" (attachment 64811 [details])
Right - "footnotes.xml" file "Good_MSO_&_ODFadd-in.docx" (attachment 64816 [details])
Comment 4 ape 2012-08-04 04:40:17 UTC
Fixed - see bug 52610.
Comment 5 Jorendc 2013-10-07 21:39:03 UTC
(In reply to comment #4)
> Fixed - see bug 52610.

lets mark it as such then :). Thanks for all your time hunting this down :)!

*** This bug has been marked as a duplicate of bug 52610 ***