Download it now!
Bug 53096 - FILEPOPEN particular .SVG: only black page filling instead of drawing shown
Summary: FILEPOPEN particular .SVG: only black page filling instead of drawing shown
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.2:OSX
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2012-08-03 12:12 UTC by Rainer Bielefeld Retired
Modified: 2019-09-16 12:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (1.88 KB, image/svg+xml)
2015-12-09 16:58 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-03 12:12:02 UTC
Steps how to reproduce with Server Installation of  "LibreOffice 3.6.0.4 rc  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit):

1. download Sample document
  <https://issues.apache.org/ooo/attachment.cgi?id=78806>
  From AOOo Bug
  <https://issues.apache.org/ooo/show_bug.cgi?id=120435>
2. Launch LibO
   > LibO Start Center appears
3. Menu 'File -> Open - Browse for sample document -> Open'
   Expected: curve shown
   Actual: all page black

Looks fine when you first start DRAW and then use menu 'Insert -> Picture from file' to insert picture.

Already a problem with LibO 3.4.5
Comment 1 Hashem Masoud 2012-10-06 08:00:38 UTC
(In reply to comment #0)
It's all black also here:
Version 3.6.1.2 (Build ID: e29a214) Slackware Linux 13.37

But how should it look like?
Comment 2 Rainer Bielefeld Retired 2012-10-06 08:19:04 UTC
(In reply to comment #1)
"Looks fine ..." from original report does not work for you? No browser or different SVG viewer available? Some minimum effort should be fair before NEEDINO ;-)

BTW, I already see that 
- with Server Installation of "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit)
- with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" 

So might be inherited from OOo.

With old versions before 3.5.7 (I did not test where exactly that started) also menu 'Insert -> Picture from file' only creates a black box.

@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf
Comment 3 Hashem Masoud 2012-10-07 06:56:49 UTC
(In reply to comment #2)
Agreed. I can see the .SVG file normally within Firefox.
Comment 4 retired 2014-01-21 09:53:19 UTC
Confirmed:4.2.0.2:OSX

Insert from menu with draw or writer open does work fine.

When using "open file" from start center and selecting svg, as reportet draw opens and shows a black page.
Comment 5 Panagiotis Issaris 2014-11-12 15:19:03 UTC
I'm having the same problem on OS X 10.9.5 with LibreOffice 4.3.2.2: Opening the SVG using "File->Open" results in a near-black page. Importnig the image using "Insert->Image->From file..." works fine.
Comment 6 Pedro 2015-05-24 22:51:42 UTC
This problem is still present in LibreOffice 5.0 Beta

Opening the Chrome logo in SVG format from
http://en.wikipedia.org/wiki/File:Google_Chrome_icon_(2011).svg
used to show a single black circle with shadow but in 5.0 Beta shows a black circle surrounded by a black ring.

Inserting this SVG in Writer shows the correct object. Shouldn't it be possible to reuse the code to display correctly in Draw?
Comment 7 Xisco Faulí 2015-12-09 16:58:17 UTC
Created attachment 121175 [details]
sample
Comment 8 Xisco Faulí 2015-12-09 17:00:31 UTC

*** This bug has been marked as a duplicate of bug 94765 ***
Comment 9 Robinson Tryon (qubit) 2015-12-17 05:49:14 UTC
Migrating Whiteboard tags to Keywords: (filter:svgOpen)
[NinjaEdit]
Comment 10 Xisco Faulí 2019-09-16 12:20:29 UTC
This is not a duplicate. bug 94765 is still reproducible in the latest version of LibreOffice, this one is fine though.

Versió: 6.3.0.4
ID de la construcció: 1:6.3.0-0ubuntu0.18.04.1~lo2
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: es-ES (ca_ES.UTF-8); Llengua de la IU: ca-ES
Calc: threaded