Bug Hunting Session
Bug 53116 - VIEWING: more than 1 minute to open Huawei NGN/IMS presentation
Summary: VIEWING: more than 1 minute to open Huawei NGN/IMS presentation
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-04 07:22 UTC by ojab
Modified: 2015-02-25 14:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
console logs on master (11.44 KB, text/plain)
2012-08-05 21:45 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ojab 2012-08-04 07:22:12 UTC
1. Open attached file.
2. LO hangs with 100% CPU load

Version 3.7.0.0.alpha0+ (Build ID: 8c739e), linux x86_64
Comment 1 ojab 2012-08-04 07:23:59 UTC
Presentation file is too large (7,9 Mb), you can download it from http://ojab.ru/huawei.pps
Comment 2 Julien Nabet 2012-08-05 21:45:33 UTC
Created attachment 65146 [details]
console logs on master

On pc Debian x86-64 with master and 3.5 sources I didn't reproduce the problem since I've got a dialog box which appear during the opening of the file.
It's Text Import about encoding and other stuff...

I opened the file after about 1 entire minute (intel Core i5, 6GB)

How do you retrieved this file ?
Did you create from scratch ?
If yes, with with Powerpoint version and on which env and localization ?
Comment 3 ojab 2012-08-06 04:29:51 UTC
Rechecked, it opens for me too, but way longer than 1 minute.
It's Huawei U-SYS NGN & IMS presentation for Russia, I've got it from Huawei. Powerpoint Viewer opens it just fine.
Comment 4 Julien Nabet 2012-08-06 08:04:35 UTC
I changed the title and put it at new since we reproduce both the same behaviour.
Comment 5 ojab 2012-08-06 08:40:37 UTC
LO for me opens presentation as text file with some mojibake instead of presentation.
LO in Fedora-17 (3.5.5.3) says "Read-Error. The loading of password-encrypted Microsoft PowerPoint presentation is not supported." and also doesn't show presentation.
Comment 6 ojab 2013-03-04 11:49:39 UTC
>The loading of password-encrypted Microsoft PowerPoint presentations is not supported.

error with latest trunk (Version 4.1.0.0.alpha0+ (Build ID: 3677953fc3358460f2c54174545ed2103e72883))

This presentation is not password encrypted, though.
Comment 7 Julien Nabet 2013-03-08 12:55:01 UTC
Thorsten/Radek: On Opengrok, searching about "password-encrypted Microsoft PowerPoint", I found it in svx/source/items/svxerr.src then I searched "ERRCODE_SVX_READ_FILTER_PPOINT" and found these lines: sd/source/filter/sdpptwrp.cxx
     99         SvStream* pDocStream = pStorage->OpenSotStream( rtl::OUString("PowerPoint Document") , STREAM_STD_READ );
    100         if( pDocStream )
    101         {
    102             pDocStream->SetVersion( pStorage->GetVersion() );
    103             pDocStream->SetCryptMaskKey(pStorage->GetKey());
    104 
    105             if ( pStorage->IsStream( rtl::OUString("EncryptedSummary" ) ) )
    106                 mrMedium.SetError( ERRCODE_SVX_READ_FILTER_PPOINT, OSL_LOG_PREFIX );
So it wouldn't be a bug but an enhancement?
Comment 8 ojab 2013-03-08 13:07:55 UTC
This presentation is _not password encrypted_, MS Office opens it without password prompt etc.
Comment 9 Julien Nabet 2013-03-08 13:20:00 UTC
ojab: you're right, sorry for the confusion.
Comment 10 Julien Nabet 2013-03-09 22:15:42 UTC
Comment on attachment 65146 [details]
console logs on master

Logs from an old version
Comment 11 Julien Nabet 2013-03-09 22:16:46 UTC
I only have these console logs now:
warn:legacy.osl:8560:1:tools/source/fsys/urlobj.cxx:3407: INetURLObject::checkHierarchical vnd.sun.star.expand
warn:sfx2.dialog:8560:1:sfx2/source/dialog/filtergrouping.cxx:361: already have an element for WordPerfect
warn:sfx2.dialog:8560:1:sfx2/source/dialog/filtergrouping.cxx:361: already have an element for writerweb8_writer_template
warn:sfx2.dialog:8560:1:sfx2/source/dialog/filtergrouping.cxx:361: already have an element for writerglobal8

(soffice:8560): GLib-GObject-WARNING **: invalid cast from `GtkAdjustment' to `GtkWindow'

(soffice:8560): GLib-GObject-WARNING **: invalid cast from `GtkAdjustment' to `GtkWidget'

(soffice:8560): GLib-GObject-WARNING **: /tmp/buildd/glib2.0-2.33.12+really2.32.4/./gobject/gsignal.c:2459: signal `focus-out-event' is invalid for instance `0x1c6ad40'
Comment 12 QA Administrators 2015-02-19 15:45:12 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 13 ojab 2015-02-25 14:14:26 UTC
Unfortunately presentation has been lost :(