Bug Hunting Session
Bug 53190 - Add Ability to Assign to keys Alt+Left, Alt+Right
Summary: Add Ability to Assign to keys Alt+Left, Alt+Right
Status: RESOLVED DUPLICATE of bug 49091
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-06 21:38 UTC by Vince
Modified: 2016-03-09 08:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince 2012-08-06 21:38:23 UTC
When using using the Customize Keyboard dialog, assignment of writer functions 
to keys Alt+F6, Alt+Left, and Alt+Right appear to "work" but subsequent use of 
those keys do not invoke the assigned function.  Other facts:

1. Assignments of functions to "similar" keys Alt+{F1-F3,F5,F7-F12,Up,Down} 
and Alt+Ctrl+{Up,Down} does work.
2. None of the above keys are assigned to any desktop function (desktop is 
KDE-3.5.10)
3. Keys appear to work properly in other desktop applications.

I filed this bug years ago with OpenOffice -- see: https://issues.apache.org/ooo/show_bug.cgi?id=113502 for details and possible insights.
Comment 1 Joel Madero 2013-06-10 15:41:57 UTC
It works fine for me on Bodhi Linux using version 4.0.3.3 release.

Marking as WFM

Note: I did notice that these key combinations were attached to other things within Enlightenment DE - for instance Alt + F6 was set to "switch to workspace #5" which I thought was a bit strange ;) But after deleting the pre-set DE combos, it worked like a charm.

Do you still experience this with version 4 release? If so, please mark as UNCONFIRMED again and we'll go forward from there.


Thanks!
Comment 2 Vince 2014-01-09 21:34:06 UTC
Well I had just about given up on getting this bug fixed when Joel Madero's update came in.  I got pretty busy with other stuff but am now able to re-visit this.

On a LO 4.1.2.3 (built from source on a very current Gentoo system), I can confirm that the bug no longer manifests with assigning the Alt+F6 but still occurs with the Alt+Left & Alt-Right key combinations -- they are completely ignored when assigned to any LO function or macro.  Instead, they behave as if one simply pressed Left or Right, and merely move the cursor.

So to add a little data, I tried this on a LS 4.0.4.2 / Windows 7 system.  Same problem.

I think the person who posted the following response to my original trouble ticket probably nailed the root cause but nevertheless I have to consider this to be a 'bug' not a 'feature'.  See https://issues.apache.org/ooo/show_bug.cgi?id=113502#c3
Comment 3 Joel Madero 2014-01-10 00:41:28 UTC
Thanks for the update. This is indeed an enhancent request not a bug. The product works as designed, you're asking for additional abilities. Bugs are when the product is designed to do X but does Y, in this case it's designed to do X and you want to add the ability to do Y. Which is fair. 

Marking as:
New
Enhancement
Lowest -- really not going to affect many users at all. You could always set different shortcuts and in 16 months not one other user has said any similar comment. 

Thanks for the suggestion
Comment 4 Buovjaga 2016-03-09 08:35:28 UTC

*** This bug has been marked as a duplicate of bug 49091 ***