Download it now!
Bug 53252 - UI: CRASH when edit LibO File Dialog Path Pane
Summary: UI: CRASH when edit LibO File Dialog Path Pane
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:3.7.0 target:3.6.1
Keywords: needUITest
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-08-08 15:25 UTC by Rainer Bielefeld Retired
Modified: 2018-02-01 17:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-08 15:25:30 UTC
Steps how to reproduce with unzipped Master Build "LOdev " 3.7.0.0.alpha0+  ENGLISH UI [Build ID: 96c5fb1]" (tinderbox:W2008R2@20, pull time 2012-08-07 23:41:15) // WIN7 Home Premium (64bit):

1. Launch LibO by double click on "soffice.exe" in WIN File Explorer
   > LibO Start Center appears
2. Menu 'Tools -> Options -> LibO -> General - Use LibO File Dialog'
3. Menu 'File -> Open'
   > File Dialog opens with "C:\Users\user\Documents" folder or similar
4. In Folder pane Select all Path Name Except Leading "C:" by mouse
5. Press <Del> key
6. <Enter>
   Expected: Path changes to "C:"
   Actual: Crash, Crash dialog appears

Also [Reproducible] with parallel installation of Master "LOdev " 3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 66e4540]" (tinderbox:Win-x86@6, pull time 2012-07-26 02:09:47)

Already reproducible with MinGW Build 2012-04-26 

NEW because reproducible with various Versions

Same for FILESAVE

Is related to new File Dialog, so no regression.
Comment 1 Urmas 2012-08-09 01:41:57 UTC

*** This bug has been marked as a duplicate of bug 46249 ***
Comment 2 Rainer Bielefeld Retired 2012-08-09 06:27:06 UTC
I am not sure that this one is a DUP of "Bug 46249 - CRASH when browse to HD root directory in FILEOPEN Template dialog". Although there is a common element "Root Directory", the way how to reproduce is very different. LibO 3.6 will NOT crash following the instructions of originalreport of Bug 46249 for the normal File dialog (clicking 'folder up' again and again). For the crash here it's necessary to reach the root directory with an edit in the folder pane (and to press <Return>.

Although Urmas' suspect concerning common roots is very plausible I prefer to leave this one separate for now.

@Urmas
Please watch progress here, too!
Comment 3 Not Assigned 2012-08-20 13:41:59 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e642eec333b9a80b04a9c19290d959de1f0ae5ff

fdo#53252: _toupper is unreliable
Comment 4 Not Assigned 2012-08-20 14:32:53 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3d9ec4630a63cfc8879371752644262e4d9b4b8&g=libreoffice-3-6

fdo#53252: _toupper is unreliable


It will be available in LibreOffice 3.6.2.
Comment 5 Rainer Bielefeld Retired 2012-08-20 15:56:52 UTC
Modified Assignee due to facts
Comment 6 Not Assigned 2012-08-20 18:48:00 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9127c6d7534d77f0ee5cf34264b682a7e97a92df&g=libreoffice-3-6-1

fdo#53252: _toupper is unreliable


It will be available already in LibreOffice 3.6.1.