Bug 53329 - FILESAVE: After I resave an xlsm file, it become corrupt
Summary: FILESAVE: After I resave an xlsm file, it become corrupt
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-10 09:12 UTC by Ákos
Modified: 2020-01-04 07:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original file (125.57 KB, application/vnd.ms-excel.sheet.macroEnabled.12)
2012-08-10 09:12 UTC, Ákos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ákos 2012-08-10 09:12:06 UTC
Created attachment 65375 [details]
Original file

After I open the attached .xlsm file, I modify some cells, and I resave it, I can't open it in Microsoft Excel 2010 or in LibreOffice 3.6.0. The file become corrupt, and I lost it.

Testcase:
Open the attached file in LibreOffice 3.6.0, insert in cell S20 the "1" value, save it in Microsoft Excel format. After I reopen the file in MS Excel 2010 or in LO 3.6.0 I got an error message.

I try in LibreOffice 3.5.5, after save, I can reopen it in LO 3.5.5 and LO 3.6.0 but I can't open it in MS Excel 2010.
Comment 1 billhook 2012-08-24 20:45:34 UTC
Confirmed on Windows Vista 32bit LO 3.6.0.4

If I save the sample document in "Excel 2007/2010 XML(.xlsx)", and then open in Office 2007, I get an error "Excel found unreadable content. Do you want to recover the contents of this workbook?"

When I click "Yes" I get:

Excel completed file level validation and repair. Some parts of this workbook may have been repaired or discarded.
Removed Part: /xl/styles.xml part with XML error.  (Styles) Load error. Line 2, column 16185.
Repaired Part: /xl/worksheets/sheet1.xml part. 
Repaired Part: /xl/worksheets/sheet3.xml part with XML error.  Load error. Line 2, column 67592.
Removed Feature: Hyperlinks from /xl/worksheets/sheet1.xml part
Removed Feature: Conditional formatting from /xl/worksheets/sheet3.xml part
Removed Records: Named range from /xl/workbook.xml part (Workbook)
Repaired Records: Cell information from /xl/worksheets/sheet1.xml part
Repaired Records: Cell information from /xl/worksheets/sheet2.xml part
Repaired Records: Column information from /xl/worksheets/sheet2.xml part
Repaired Records: Conditional formatting from /xl/worksheets/sheet2.xml part
Repaired Records: Cell information from /xl/worksheets/sheet3.xml part
Repaired Records: Cell information from /xl/worksheets/sheet4.xml part

The spreadsheet *looks* reasonable then... at first glance anyway.

In LO 3.6.04, if I open the file I get:

"General Error. General input/output error"

The document then doesn't open at all.
Comment 2 Ákos 2012-12-13 13:40:23 UTC
In LibreOffice 4.0.0 beta1 I got:
General Error. General imput/output error.
Comment 3 Ákos 2013-09-23 08:16:05 UTC
I try it with LibreOffice 4.1.2 RC2, after modify the file, I can open it in LibreOffice 4.1.2 RC2 but I can't open it in Microsoft Excel 2013. I got the error:
Excel cannot open the file '...' because the file format or the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file.
Comment 4 Ákos 2014-01-23 15:45:02 UTC
I retest in LibreOffice 4.2.0 RC2:
- after modifcation I can open it in LibreOffice
- I can't open it in Microsoft Excel 2013
Comment 5 Ákos 2014-11-10 10:51:26 UTC
I retest in LibreOffice 4.3.2.2:
- after modifcation I can open it in LibreOffice
- I can't open it in Microsoft Excel 2013
Comment 6 Ákos 2015-06-04 07:20:32 UTC
I retest in LibreOffice 5.0.0.0.beta1, 32 bit:
- after modifcation I can open it in LibreOffice
- I can't open it in Microsoft Excel 2013
Comment 7 Xisco Faulí 2015-08-20 15:53:10 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 8 Bartosz 2016-08-02 23:47:48 UTC
Problem is not existing with LO 5.1.4.2 on Ubuntu 16.04 and it is working correctly for me.
Comment 9 Ákos 2016-08-03 07:09:50 UTC
I can confirm with LibreOffice 5.2.0.4 in windows too.
Comment 10 Enchantresse 2020-01-04 07:12:12 UTC
This kind of error occurs when proper instructions and guidelines are not being followed. Visit https://www.assignmenthelper.com.au/math-assignment-help/ to know more help in essays. Such files should be opened in the advanced versions of Microsoft Excel otherwise you may not get required results.