Bug 53419 - FILESAVE: Math objects in Impress doesn't display in Powerpoint when file is saved as .pptx
Summary: FILESAVE: Math objects in Impress doesn't display in Powerpoint when file is ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:5.2.0 target:5.1.1
Keywords: filter:ooxml
Depends on:
Blocks: 97356
  Show dependency treegraph
 
Reported: 2012-08-12 18:28 UTC by Roberto
Modified: 2016-10-25 19:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto 2012-08-12 18:28:59 UTC
Problem description: 

When you are working with Math and Impress, and save the presentation as a .ppt or a .pptx file, Math objects doesn't appear in the presentation when it is opened with MS PowerPoint (2007 or 2010 verison, any of them). 

Steps to reproduce:
1. Open L.O Impress.
2. Clic Insert --> Formula.
3. Write a simple math formula, for example: sqrt{{1 + x} over {1 - x}}, and save it in your presentation.
4. In Impress, go to File --> Save as, and save your document as a .ppt or a .pptx file.
5. Open your .ppt or .pptx file with MS PowerPoint 2007 or 2010.

Current behavior: your equation won't appear.

Expected behavior: yout equation should appear.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Joel Madero 2012-12-30 17:19:55 UTC
Version 3.6.3.2 (Build ID: 58f22d5)

Able to reproduce for pptx NOT for ppt, changed title to reflect this.

Marking as:
NEW (confirmed)

Major - Can result in loss of data if a user saves with new pptx format. Wouldn't know until file is closed and then reopened

Medium - lowered default from HIGH because mixing math with impress is already pretty rare, add on saving as PPTX and it becomes something which probably doesn't affect many users. No comments in 4+ months is further indication.


If it's still an issue with ppt files on a newer release please leave a comment so developers know that at least for one person it's still a problem for ppt (you can also edit the title back to include it if you feel it's appropriate). 

Thanks for reporting!
Comment 2 Roberto 2013-01-08 03:14:52 UTC
(In reply to comment #1)
> Version 3.6.3.2 (Build ID: 58f22d5)
> 
> Able to reproduce for pptx NOT for ppt, changed title to reflect this.
> 
> Marking as:
> NEW (confirmed)
> 
> Major - Can result in loss of data if a user saves with new pptx format.
> Wouldn't know until file is closed and then reopened
> 
> Medium - lowered default from HIGH because mixing math with impress is
> already pretty rare, add on saving as PPTX and it becomes something which
> probably doesn't affect many users. No comments in 4+ months is further
> indication.
> 
> 
> If it's still an issue with ppt files on a newer release please leave a
> comment so developers know that at least for one person it's still a problem
> for ppt (you can also edit the title back to include it if you feel it's
> appropriate). 
> 
> Thanks for reporting!

Thank you very much. I'll try with version 3.6.3 or latest. 
Only a little note: I´m a school math teacher and, very often, I and my colleagues use PowerPoint presentations as additional material for our classes. In this context, using LaTex isn't a good idea, so we use PowerPoint with Math Type or, in my case, LO Impress with Math. Browsing the internet, you will find many material (containing mathematical expressions) bluit with PowerPoint, but the poor integration of math symbols inside it, makes the resulting presentations a little bit dissapointing and unprofessional.
In this sense, Math integration inside Impress is much better, so mixing both is not so rare, and being able to save your work in ppt format is necessary in order to share it with others.
Comment 3 QA Administrators 2015-02-19 15:43:05 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-03-16 19:01:56 UTC
(In reply to Joel Madero from comment #1)
> Able to reproduce for pptx NOT for ppt

Same result here.

Win 8 32-bit
MSO 2013
LibreOffice Version: 4.5.0.0.alpha0+
Build ID: 460b17d2712a80331a83329d2951f3e0303835cd
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-14_23:10:42
Locale: fi_FI
Comment 5 Michael Stahl (CIB) 2016-01-25 09:58:11 UTC
i've implemented the export in commit cb890ae43bacd2be24bc74fad2e2e5cce8910995 on master

backported to libreoffice-5-1 as commit 68d351fff469d0ab75f817a4e217194735258da8

note that the OOXML math markup in PPTX isn't actually specified in ECMA-376 3rd ed., and can only be read by PPT 2010, not by PPT 2007 (AFAIK)