Bug 53457 - Numeric pad in calc gives unpredictable results with decimal numbers
Summary: Numeric pad in calc gives unpredictable results with decimal numbers
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-13 20:22 UTC by Ludovic CHERON
Modified: 2012-08-14 00:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic CHERON 2012-08-13 20:22:28 UTC
LibreOffice Calc
LibreOffice 3.5.4.2 
Version ID : 350m1(Build:2)
System Ubuntu 12.04 (up to date) in VirtualBox
Langage : French (this may be important)

Using numeric pad to enter numbers
Enter : 2 displays 2
Enter : 2.0 (2 dot zero) displays 01/02/00
Lets convert this to a number format (instead of date)
Format/cellule categorie=nombre, format=standard and OK
Cell now displays.... 36557
oops !

Enter 2.1 in the same cell
Re-do format
Cell now displats ... 40910
re oops

ok ok i should have typed 2,5 (2 coma 5)...
but this is a spreadsheet bug source
Comment 1 Markus Mohrhard 2012-08-14 00:04:11 UTC
This is not a bug. This is a feature called partial date input. There are some date acceptance  patterns based on your local that transform input automatically into dates if they can't be numbers.

Dates are internally nothing else than numbers so everything here is working correctly.