Bug 53550 - : Make mailmerge steps more accessible
Summary: : Make mailmerge steps more accessible
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2012-08-15 18:22 UTC by Jared
Modified: 2017-07-14 12:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jared 2012-08-15 18:22:19 UTC
Problem description: Inserting additional mailmerge fields takes too many steps to be done easily, by a notice and seems poor design of accessibility.  To increase the visibility of the mailmerge functions in Writer inserting Database fields should be more accessible.

Steps to reproduce:
1. Open Writer document
2. Navigate to Insert->Fields

Current behavior: Database fields is accessible through clicking on "Other.." and the proceeding dialog window.

Expected behavior: Database fields ought to be available immediately in the Fields submenu of the Insert menu. 

This will allow for less clicks, and a corresponding dialog window which could be simpler by being simply dedicated to Database fields.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.2; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 Brenda Granados 2013-03-18 15:25:39 UTC
Hi. If you already have a database with the fields you need, there is another way. After you open a file in Writer, go to View -> Data Sources, or press F4.
Then, in the left-hand side of the new window that opens above your document, select your database table. The table will open on the right. You can drag and drop the field names onto your document.

But I do see what you are saying about accessing the fields through Insert -> Fields... Other. I think it is fairly easy to use one database, but if the user needs to pull in from several databases, either option would be a lot of clicks. I will set the status of this as a new ENHANCEMENT request.

Thank you for submitting this report!

Version: Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
Platform: Ubuntu Linux 12.04 LTS x64

-------------------------------------------------------

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage  There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists
Comment 2 Alex Thurgood 2015-01-03 17:38:24 UTC Comment hidden (no-value)
Comment 3 Adolfo Jayme 2016-05-19 20:33:05 UTC
In LibreOffice 5.2 we reworked mail merge and reduced the amount of steps needed. You might want to download a daily build [1], play with it, and report back.

[1]: http://dev-builds.libreoffice.org/daily/
Comment 4 Timur 2017-07-14 12:18:14 UTC
Brenda gave and explanation for the reported problem: use View -> Data Sources, or press F4.

This was confirmed as enhancement but without clearly defining aim. At least, title "Make mailmerge steps more accessible" is not sufficient. 

We have "Expected behavior: Database fields ought to be available immediately in the Fields submenu of the Insert menu."
I don't think is feasible to have it in Fields submenu. Even in Insert menu, that would save a single click, but I wouldn't use it myself for Mailmerge, beside Data Sources. 

For the sake of efficiency, since there was no responses before, I'll close this as NotaBug. If you object, please respond with exact expectations. 
In case I'm wrong, I add other colleagues to CC for a review.