Bug 53816 - FILEOPEN: Writer doesn't "allow row to break across pages" in DOCX with large multi-page table
Summary: FILEOPEN: Writer doesn't "allow row to break across pages" in DOCX with large...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-19 19:49 UTC by Mikeyy - L10n HR
Modified: 2016-07-27 10:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx (363.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-08-19 19:49 UTC, Mikeyy - L10n HR
Details
.doc (1.28 MB, application/msword)
2012-08-19 19:50 UTC, Mikeyy - L10n HR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikeyy - L10n HR 2012-08-19 19:49:18 UTC
Created attachment 65808 [details]
.docx

You can find docx and doc files in attachment.
Open it with LO and you will see only 3 pages, and not shown correctly.
If you open it with Office 2010 you will see 114 pages of text.

Tryed saving docx into doc with Office 2010 and then opening with LO, but that didn't work.

I replaced almost all letters with X since this was contract.

Also, opening this file with LO takes ages. For .doc it took over 1 min on 4GB ram, Win7 64bit fast machine. And then it shows only 3 inacurate pages.
Comment 1 Mikeyy - L10n HR 2012-08-19 19:50:03 UTC
Created attachment 65809 [details]
.doc
Comment 2 Timon 2012-09-07 09:27:18 UTC
Confirmed in LibO 3.6.1.2 Final (Build ID: e29a214) Russian UI/Locale on Russian
Windows XP Professional SP3 (32bit)

In .docx and .doc there are only 3 pages shown, but word count says that files contain:
.docx - 41786 words
.doc - 40497 words

Import of files is very slow
Comment 3 Timon 2012-09-07 18:08:04 UTC
In MSOffice 2003 SP3 Russian UI/Locale on Russian Windows XP Professional SP3 (32bit) with File Format Converter - all is fine

In .docx and .doc shown all 114 pages, word count (statistics) says that files contain:
.docx - 41086 words
.doc - 41087 words

There is a suspicion that one of office suites incorrectly count quantity of words (LibO shows 41786 words in .docx and 40497 words in .doc)
Comment 4 Timon 2012-09-10 04:59:39 UTC
In Apache Open Office 3.4.1 Final Russian UI/Locale on Russian Windows XP Professional SP3 (32bit)

In .docx and .doc there is the same problem - only 3 pages shown, word count says that files contain:
.docx - 41990 words
.doc - 40826 words

Import of .doc file is extremely slow, .docx opens very fast.

All 3 office suites count different quantity of words.
Comment 5 Timon 2013-10-04 12:19:54 UTC
Problem still present in LibreOffice 4.1.2.3 Final, Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
Comment 6 QA Administrators 2015-04-01 14:42:09 UTC Comment hidden (obsolete)
Comment 7 Mikeyy - L10n HR 2015-04-01 16:22:02 UTC
Still valid bug.
LO 4.4.2.2 on Windows 7, 64 bit, Intel i3 3240, 8 GB of ram, SSD disk

DOCX - takes 19 sec to open, opens only 3 pages (first empty)
DOC - takes 35 sec to open, opens only 3 pages (first empty)

Windows WordPad opens DOCX file in 9 seconds, all 100+ pages.

LO 3.3.0.4, portable version, needs 76 seconds to open DOC document, it opens 3 pages (first empty).
Comment 8 Timur 2015-08-25 17:16:46 UTC
It's a large multi-page table in DOCX with 2 columns and 1 row on 114 pages. 
Writer sometimes doesn't handle properly Text Flow options from DOCX, here it's "allow row to break across pages". If that option is turned off in Word, it also shows 3 pages.
I adapted the title.

BTW, similar files cannot be open or are even more slow in the current master LO 5.1+.
Comment 9 Timon 2016-07-27 06:49:47 UTC
As I see, problem was fixed in LibreOffice Version: 5.2.0.3
Build ID: 7dbd85f5a18cfeaf6801c594fc43a5edadc2df0c
OS Version: Windows 5.1; Locale: ru-RU (ru_RU)

Now in both files I see all 115 pages and can scroll throw them. Word count shows that files contain:
.docx - 40819 words
.doc - 40818 words
Import of files is still rather slow.
Comment 10 Mikeyy - L10n HR 2016-07-27 07:10:24 UTC
(In reply to Timon from comment #9)
> As I see, problem was fixed in LibreOffice Version: 5.2.0.3

Yes, I can confirm, both documents load.
Docx somewhat faster, around 30-40 seconds, but doc loading is still very very slow, way more then 1 min.

Should this bug be renamed and focus only on speed of opening now, or closed as fixed (or works for me)?
Comment 11 Timur 2016-07-27 09:55:55 UTC
Bug is about fileopen and it's WFM, so I close. It's fixed from 5.0.6 (maybe Bug 99140). Performance is a different issue.