Download it now!
Bug 53838 - Tools-> Macros -> Run Macros, crashes office
Summary: Tools-> Macros -> Run Macros, crashes office
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-20 11:59 UTC by Björn Michaelsen
Modified: 2012-12-11 16:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2012-08-20 11:59:59 UTC
Master on commit 2b9dbc8ad1640a62f71d75aede0250dc34d96224 from Mon Aug 13 06:57:51 2012 +0200 reproducible crashes here when clicking Tools-> Macros -> Run Macros. Tools-> Macros -> Organize seems to be fine though.

Possibly related to or a resurrection of:

 https://bugs.freedesktop.org/show_bug.cgi?id=49291

thus cc'in sberg.
Comment 1 Björn Michaelsen 2012-08-20 12:00:58 UTC
see also: https://bugs.freedesktop.org/show_bug.cgi?id=53408
Comment 2 Christina Rossmanith 2012-09-25 20:26:07 UTC
Not reproducible here with:

Version 3.7.0.0.alpha0+ (Build ID: 784302d)

last git pull probably on 31th July 2012
Comment 3 Terrence Enger 2012-11-15 03:34:59 UTC
By taking menu options Tools > Macros > "Run Macro", I have executed
all four macros in "LibreOffice Macros" > HelloWorld.  No crash.

My LibreOffice is master commit f1b6058, pulled 2012-10-13, and very
lightly hacked.  The configuration options are ...

    --enable-symbols
    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --without-system-postgresql
    --enable-debug
    --enable-werror

and the environment for build and execution is ubuntu-natty (11.04)
32-bit ...

    $ uname -a
    Linux cougar-natty 2.6.38-16-generic #67-Ubuntu SMP Thu Sep 6 18:00:43 UTC 2012 i686 athlon i386 GNU/Linux
    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2


HTH,
Terry.
Comment 4 Joel Madero 2012-12-06 18:08:23 UTC
I am not seeing this bug:

Version 4.1.0.0.alpha0+ (Build ID: dfd474710f959dcf78038deb990c3618b467ec6)

Björn you still seeing this with more recent pull? If not can we mark as WFM?
Comment 5 Rob Snelders 2012-12-06 22:49:10 UTC
Not seeing this problem with 4.1.0.0-master on Ubuntu 12.04 x86_64 (Build ID: 8e43393c9514f39e6b43e581503b61177a00bd36)
Comment 6 Joel Madero 2012-12-11 16:00:37 UTC
Marking as WORKSFORME as Rob and I have confirmed that it doesn't seem to be a problem any longer.

Bjoern if you're still showing it please open it back up :)