Download it now!
Bug 53881 - FILEOPEN: DocX Document Deadlocks LibreOffice
Summary: FILEOPEN: DocX Document Deadlocks LibreOffice
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-21 13:43 UTC by Dave Richards
Modified: 2015-09-14 16:07 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Errant document (69.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-08-21 13:44 UTC, Dave Richards
Details
GDB backtrace (10.26 KB, text/plain)
2012-08-21 13:44 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2012-08-21 13:43:43 UTC
We received the attached DOCX document which deadlocks both LibreOffice 3.5 and 3.6.  In 3.5 the canvas does update long enough to see the top part of the document and then it locks.  In 3.6 is immediately locks.

Document is attached along with the GDB backtrace of the running application.
Comment 1 Dave Richards 2012-08-21 13:44:19 UTC
Created attachment 65883 [details]
Errant document
Comment 2 Dave Richards 2012-08-21 13:44:54 UTC
Created attachment 65884 [details]
GDB backtrace
Comment 3 Michael Meeks 2012-08-21 16:08:08 UTC
Fairly typical layout loop - these tend to be rather specific to one document and tend to take a long time to fix; we've had another like it as a 3.5 MAB for a while I'm afraid.

Traces with debugging symbols are far more useful:

Thread 1 (Thread 0xb33b6a80 (LWP 24884)):
#0  0xb670efa3 in SfxItemSet::Get (this=0xad3205e0, nWhich=15, bSrchInParent=1 '\001')
    at /ssd/opt/libreoffice/master/svl/source/items/itemset.cxx:986
#1  0xadbe9d29 in GetWeight (bInP=1 '\001', this=0xad3205e0) at /ssd/opt/libreoffice/master/sw/inc/charatr.hxx:35
#2  SwFont::SwFont (this=0x8cd01b0, pAttrSet=0xad3205e0, pIDocumentSettingAccess=0x86b2f14)
    at /ssd/opt/libreoffice/master/sw/source/core/txtnode/swfont.cxx:467
#3  0xadbc216f in SwTxtFormatter::NewFtnNumPortion (this=0xbfffcedc, rInf=...)
    at /ssd/opt/libreoffice/master/sw/source/core/text/txtftn.cxx:1022
#4  0xadb99275 in SwTxtFormatter::WhichFirstPortion (this=0xbfffcedc, rInf=...)
    at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:1066
#5  0xadb9ae43 in SwTxtFormatter::NewPortion (this=0xbfffcedc, rInf=...) at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:1214
#6  0xadb9c1a3 in SwTxtFormatter::BuildPortions (this=0xbfffcedc, rInf=...) at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:716
#7  0xadb9cd7b in SwTxtFormatter::FormatLine (this=0xbfffcedc, nStartPos=0) at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:1545
#8  0xadb846a9 in SwTxtFrm::FormatLine (this=0xac522df8, rLine=..., bPrev=0 '\000')
    at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1126
#9  0xadb866fc in SwTxtFrm::_Format (this=0xac522df8, rLine=..., rInf=..., bAdjust=0 '\000')
    at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1488

hang to here - 'finish' fails to complete in this method.

#10 0xadb86db3 in SwTxtFrm::_Format (this=0xac522df8, pPara=0xa9ee9278) at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1662
#11 0xadb874a2 in SwTxtFrm::Format (this=0xac522df8) at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1812
#12 0xadaf477a in SwCntntFrm::MakeAll (this=0xac522df8) at /ssd/opt/libreoffice/master/sw/source/core/layout/calcmove.cxx:1400
#13 0xadaf22ca in SwFrm::PrepareMake (this=0xac522df8) at /ssd/opt/libreoffice/master/sw/source/core/layout/calcmove.cxx:384
#14 0xad99ef76 in SwFrm::Calc (this=0xac522df8) at /ssd/opt/libreoffice/master/sw/source/core/inc/frame.hxx:1031
#15 0xadb14a5c in SwFtnBossFrm::AppendFtn (this=0xace1a078, pRef=0xace0212c, pAttr=0x87dced0)
    at /ssd/opt/libreoffice/master/sw/source/core/layout/ftnfrm.cxx:1789
#16 0xadbc1d2c in SwTxtFrm::ConnectFtn (this=0xace0212c, pFtn=0x87dced0, nDeadLine=22264)
    at /ssd/opt/libreoffice/master/sw/source/core/text/txtftn.cxx:727
#17 0xadbc2c56 in SwTxtFormatter::NewFtnPortion (this=0xbfffdfcc, rInf=..., pHint=0x87dced0)
    at /ssd/opt/libreoffice/master/sw/source/core/text/txtftn.cxx:893
#18 0xadbb74e4 in SwTxtFormatter::NewExtraPortion (this=0xbfffdfcc, rInf=...) at /ssd/opt/libreoffice/master/sw/source/core/text/txtfld.cxx:373
#19 0xadb9b2c5 in SwTxtFormatter::NewPortion (this=0xbfffdfcc, rInf=...) at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:1327
#20 0xadb9c1a3 in SwTxtFormatter::BuildPortions (this=0xbfffdfcc, rInf=...) at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:716
#21 0xadb9cd7b in SwTxtFormatter::FormatLine (this=0xbfffdfcc, nStartPos=259)
    at /ssd/opt/libreoffice/master/sw/source/core/text/itrform2.cxx:1545
#22 0xadb846a9 in SwTxtFrm::FormatLine (this=0xace0212c, rLine=..., bPrev=0 '\000')
    at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1126
#23 0xadb866fc in SwTxtFrm::_Format (this=0xace0212c, rLine=..., rInf=..., bAdjust=0 '\000')
    at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1488
#24 0xadb86db3 in SwTxtFrm::_Format (this=0xace0212c, pPara=0xa9ee9140) at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1662
#25 0xadb874a2 in SwTxtFrm::Format (this=0xace0212c) at /ssd/opt/libreoffice/master/sw/source/core/text/frmform.cxx:1812
#26 0xadaf477a in SwCntntFrm::MakeAll (this=0xace0212c) at /ssd/opt/libreoffice/master/sw/source/core/layout/calcmove.cxx:1400
#27 0xadaf238d in SwFrm::OptPrepareMake (this=0xace0212c) at /ssd/opt/libreoffice/master/sw/source/core/layout/calcmove.cxx:403
#28 0xadb1aa26 in SwFrm::OptCalc (this=0xace0212c) at /ssd/opt/libreoffice/master/sw/source/core/inc/frame.hxx:1036
#29 0xadb175b5 in SwLayAction::_FormatCntnt (this=0xbfffe86c, pCntnt=0xace0212c, pPage=0xace1a078)
    at /ssd/opt/libreoffice/master/sw/source/core/layout/layact.cxx:1970
#30 0xadb1791f in SwLayAction::FormatCntnt (this=0xbfffe86c, pPage=0xace1a078)
    at /ssd/opt/libreoffice/master/sw/source/core/layout/layact.cxx:1794
#31 0xadb1a010 in SwLayAction::InternalAction (this=0xbfffe86c) at /ssd/opt/libreoffice/master/sw/source/core/layout/layact.cxx:897
#32 0xadb1a2c7 in SwLayAction::Action (this=0xbfffe86c) at /ssd/opt/libreoffice/master/sw/source/core/layout/layact.cxx:470
#33 0xadb1a4cb in SwLayIdle::SwLayIdle (this=0xbfffe928, pRt=0x874a158, pI=0x8749ec0)
    at /ssd/opt/libreoffice/master/sw/source/core/layout/layact.cxx:2346
#34 0xadcea8b3 in ViewShell::LayoutIdle (this=0x8749d10) at /ssd/opt/libreoffice/master/sw/source/core/view/viewsh.cxx:714
#35 0xad9fce1a in SwDoc::DoIdleJobs (this=0x86b2f10, pTimer=0x86b2f94) at /ssd/opt/libreoffice/master/sw/source/core/doc/doclay.cxx:1875
#36 0xad9fcfdd in SwDoc::LinkStubDoIdleJobs (pThis=0x86b2f10, pCaller=0x86b2f94)
    at /ssd/opt/libreoffice/master/sw/source/core/doc/doclay.cxx:1834
#37 0xb6db3c6a in Call (pCaller=0x86b2f94, this=0x86b2fa4) at /ssd/opt/libreoffice/master/solver/unxlngi6.pro/inc/tools/link.hxx:123
#38 Timer::Timeout (this=0x86b2f94) at /ssd/opt/libreoffice/master/vcl/source/app/timer.cxx:254
#39 0xb6db3d19 in Timer::ImplTimerCallbackProc () at /ssd/opt/libreoffice/master/vcl/source/app/timer.cxx:142
#40 0xb2ae588b in CallCallback (this=<optimized out>) at /ssd/opt/libreoffice/master/vcl/inc/saltimer.hxx:57
#41 sal_gtk_timeout_dispatch (pSource=0x8a71958) at /ssd/opt/libreoffice/master/vcl/unx/gtk/app/gtkdata.cxx:839
#42 0xb45f3e2f in g_main_dispatch (context=0x8083010) at gmain.c:2425
#43 g_main_context_dispatch (context=0x8083010) at gmain.c:2995
#44 0xb45f4560 in g_main_context_iterate (context=0x8083010, block=-1268764848, dispatch=1, self=<optimized out>) at gmain.c:3073
#45 0xb45f47fa in g_main_context_iteration (context=0x8083010, may_block=1) at gmain.c:3136
#46 0xb2ae5503 in GtkData::Yield (this=0x8052190, bWait=true, bHandleAllCurrentEvents=false)
    at /ssd/opt/libreoffice/master/vcl/unx/gtk/app/gtkdata.cxx:583
#47 0xb2ae59f5 in GtkInstance::Yield (this=0x8052160, bWait=true, bHandleAllCurrentEvents=false)
    at /ssd/opt/libreoffice/master/vcl/unx/gtk/app/gtkinst.cxx:538
#48 0xb6db0424 in ImplYield (i_bWait=true, i_bAllEvents=false) at /ssd/opt/libreoffice/master/vcl/source/app/svapp.cxx:434
#49 0xb6dae198 in Application::Yield (i_bAllEvents=false) at /ssd/opt/libreoffice/master/vcl/source/app/svapp.cxx:468
#50 0xb6dae1c9 in Application::Execute () at /ssd/opt/libreoffice/master/vcl/source/app/svapp.cxx:413
#51 0xb66c112d in desktop::Desktop::Main (this=0xbfffef14) at /ssd/opt/libreoffice/master/desktop/source/app/app.cxx:1679
#52 0xb6db39d9 in ImplSVMain () at /ssd/opt/libreoffice/master/vcl/source/app/svmain.cxx:172
#53 0xb6db3b0c in SVMain () at /ssd/opt/libreoffice/master/vcl/source/app/svmain.cxx:209
#54 0xb66d283d in soffice_main () at /ssd/opt/libreoffice/master/desktop/source/app/sofficemain.cxx:85
#55 0x0804856c in sal_main () at /ssd/opt/libreoffice/master/desktop/source/app/main.c:25
Comment 4 Jorendc 2013-02-17 18:47:36 UTC
Still reproducible using LibreOffice Version 4.1.0.0.alpha0+ (Build ID: c16e9f4ed97f65357e9986f46ad88ee9f223799) Linux Mint 14 x64.
Comment 5 Jorendc 2013-12-28 23:56:49 UTC
Still reproducible using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 5be7ec4193b892e5643ff5f3f2e6755319569190
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-27_23:55:02

Document deadlocks after loading.
Comment 6 QA Administrators 2015-04-19 03:23:30 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 7 Gordo 2015-04-20 17:55:14 UTC
Still reproducible.

Windows Vista 64
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 8 Dave Richards 2015-09-14 15:18:08 UTC
This document opens correctly in 5.0.3, so somewhere along the line the root causes was fixed.  Closing.
Comment 9 Timur 2015-09-14 16:07:08 UTC
If a specific commit/fix is not known, then it's not Fixed, but WorksForMe.
Looks like a duplicate of Bug 79018 to me.