Bug Hunting Session
Bug 53901 - Create Extension which Enables Per Component Default Paths
Summary: Create Extension which Enables Per Component Default Paths
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog-Paths
  Show dependency treegraph
 
Reported: 2012-08-22 00:52 UTC by Roger Davis
Modified: 2017-12-06 20:40 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Davis 2012-08-22 00:52:55 UTC
There is no way to specify default document directories for each or any component.  

This is one of the most basic defaults for any software.  It should be remedied immediately.
Comment 1 Jean-Baptiste Faure 2012-08-25 16:28:23 UTC
What about menu Tools > Options > LibreOffice > Paths -> My documents ?

Status set as NEEDINFO: we need infos from you to be able to go forward.

Best regards. JBF
Comment 2 Roger Davis 2012-08-28 05:40:36 UTC
What I'm trying to do is:
/home/roger/Documents/2012/Libre Office
- /home/roger/Documents/2012/Libre Office/Calc
- /home/roger/Documents/2012/Libre Office/Draw
- /home/roger/Documents/2012/Libre Office/Impress
- /home/roger/Documents/2012/Libre Office/Math
- /home/roger/Documents/2012/Libre Office/Writer
 - etc...

and later:
/home/roger/Documents/2013/Libre Office
- /home/roger/Documents/2013/Libre Office/Calc
- /home/roger/Documents/2013/Libre Office/Draw
- /home/roger/Documents/2013/Libre Office/Impress
- /home/roger/Documents/2013/Libre Office/Math
- /home/roger/Documents/2013/Libre Office/Writer
 - etc...

What the current status allows is simply:
/home/roger/Documents/Libre Office, no further distinction is possible.

Microsoft Office (I hate to use it as an example) provides a default setting for each app within the suite.

Thanks!
Comment 3 Jean-Baptiste Faure 2012-08-28 07:54:53 UTC
(In reply to comment #2)
> [...] 
> Microsoft Office (I hate to use it as an example) provides a default setting
> for each app within the suite.

Perhaps, and ?

From my point of view it is a very bad idea. But you are free to submit a patch or discuss the idea on ux-advice mailing list : http://nabble.documentfoundation.org

Not a bug anyway; so set to enhancement.

Best regards. JBF
Comment 4 Roger Davis 2012-08-28 23:30:49 UTC
I would like very much to know why it is a "very bad" idea.  At the very worst, it seems that "It's too much trouble" would be the most negative reasonable statement.  What makes it so "very bad"?

Thanks!
Comment 5 Jean-Baptiste Faure 2012-08-29 04:56:08 UTC
(In reply to comment #4)
> I would like very much to know why it is a "very bad" idea.  At the very worst,
> it seems that "It's too much trouble" would be the most negative reasonable
> statement.  What makes it so "very bad"?

Because OpenDocument is a standard format, not devoted to a single software.
What to do if you want use LO and AOO in parallel ?

It is far better to organize your documents from what they mean for you: accounting, mail, writing, etc. In each directory you may have different kinds of documents, spreadsheets, text, images, drawing, etc.
You may have for the same subject a spreadsheet and a text document. Why do you want to store them in different directories?

Best regards. JBF
Comment 6 Roger Davis 2012-08-29 05:11:03 UTC
It is for simple easy convenience to automatically store a document in a directory that is organized in some way already - in my case, by year of creation and document type. For most, this would be simply document type.  It's easy to do and easy to find later.

If someone wants to have two different types of documents on a given subject, they can either put them in a special directory or give them matching names in the different directories.

The easy answer to this question that will satisfy everyone is to make the ability to set different default directories for each app in LibreOffice, but at installation they would all be set to the same default directory as it is now.  That way, all things are possible.  If one never needs to set a different default, they never need to touch it.  If one needs a different setting, the have only to set it as they like.  No harm, no foul - no problem.

Thanks!
Comment 7 Joel Madero 2013-06-10 17:19:18 UTC
Stefan - is this a UX issue? Not really sure who to ask about this one, I either want to close it as WONTFIX or mark as NEW as enhancement request -

@Roger - have you considered just using a simple bash script for this? I believe it would be quite easy - I may even know someone who could help make it
Comment 8 Roger Davis 2013-06-11 00:17:21 UTC
While I appreciate the offer of assistance, if I am able to get directories set up for each app in the suite, what happens when there is an upgrade?

On the other hand, if it's so easy to fix on an individual basis, why is it so hard just to make it like the competition and be able to name a directory for each app to save it's files to, and have the directory as a user entered / selected variable?  Of course, installation defaults can be set and utilized  without change if there is no desire to change the location.

If you have lots of documents, it greatly reduces frustration, lost time, confusion, annoyance, etc...

I strongly suggest enhancement request.

Thanks!
Comment 9 Stefan Knorr (astron) 2013-06-12 16:48:14 UTC
Hm... not sure about this one. Obviously, it is a UX issue, but to me, there are
two reasons, why this idea seems less than great to me:

* LibreOffice is one program, not many like MSO is – of course, it doesn't
  always seem that way, but I think we should embrace that in some ways (share
  implementations, UI concepts, …)

* I think (hope?) most people have some central Documents folder (modern OS's
  all create one) and then create subfolders for specific projects in them that
  may contain files from multiple applications. E.g. for presentations, I often
  have a text document with my notes, the presentation itself & maybe some
  additional videos.

* It would significantly increase the complexity of the paths options page that
  already allows to much customisation. (Documents, Templates, Graphics should
  be the only configurable paths there, imnsho.)

So, no definitive "no" from me, but I'd tend to say, most people probably don't
need this. Maybe someone could write a macro/an extension?
Comment 10 Stefan Knorr (astron) 2013-06-12 16:49:54 UTC
^two^three
*I can't count.*
Comment 11 Joel Madero 2013-06-12 16:53:12 UTC
I tend to agree Astron - an extension seems manageable - and therefore....do we mark this as an enhancement request as an extension? I'd +1 that idea, making it part of the core code seems less than ideal IMO
Comment 12 Joel Madero 2014-05-28 17:39:49 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform: Ubuntu Linux 14.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Low - a few problems with the idea (that Astron pointed out) and this is an extension which means it is outside of the core of LibreOffice

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 13 Thomas Lendo 2017-12-03 19:33:19 UTC
Adding needsUXEval as this is an IX issue and maybe it's not want anymore today.
Comment 14 Heiko Tietze 2017-12-06 20:40:06 UTC
We talked about this topic in the design meeting and agreed on WONTFIX. It's a very special workflow and better realized with an extension (which makes this request not a ticket on the LibO BZ).