Bug 54047 - VIEWING: zoom in or zoom out with CTRL + "with mouse wheel" is not centered !
Summary: VIEWING: zoom in or zoom out with CTRL + "with mouse wheel" is not centered !
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-25 09:41 UTC by Alex
Modified: 2013-08-20 12:53 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2012-08-25 09:41:12 UTC
Problem description: 

Steps to reproduce:
1. Open a long document (more pages) with incorporated text, frames, images...etc.
2. use CTRL + "mouse wheel rotation" to zoom-in or zoom-out a portion of the document.

Current behavior:
The zoom (in or out) cause losting the current position of document displayed; so it is necessary to scroll down or to scroll up to set the last position in the document!

Expected behavior:
The zoom in and zoom out operations are centered on the mouse cursor position showing the same portion of document zoomed in or zoom out. This is not better?

Platform (if different from the browser): Win7 32 bit.
Comment 1 A (Andy) 2013-02-16 19:54:42 UTC
not reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

@Alex: Does this issue still persist with the latest release of LO?

Can anybody else confirm this behavior?
Comment 2 Alex 2013-02-17 15:33:37 UTC
In version 4.0.0.3 of Libreoffice the issue seems fixed.
But it might be fixed better by keeping the position of the text cursor always in the middle of the height of the client area, 
and this for all steps of zoom factors and for all actions of resizing of the window ( sizing border’s action or restore/maximize’s action).

Thank you.

From: bugzilla-daemon@freedesktop.org 
Sent: Saturday, February 16, 2013 8:54 PM
To: alexrnz666@alice.it 
Subject: [Bug 54047] VIEWING: zoom in or zoom out with CTRL + "with mouse wheel" is not centered !


Comment # 1 on bug 54047 from A 
not reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

@Alex: Does this issue still persist with the latest release of LO?

Can anybody else confirm this behavior?
--------------------------------------------------------------------------------
You are receiving this mail because: 
  a.. You reported the bug.
Comment 3 A (Andy) 2013-02-23 11:49:57 UTC
@Alex: Thank you very much for your very fast feedback.  According to this I have marked this special issue as resolved.  But regarding your enhancement proposal could you please open an enhancement "bug" for this, so that somebody will also take a look at this additional proposal?
Comment 4 Krunoslav Šebetić 2013-08-20 12:53:38 UTC
I can reproduce this on Debian Wheezy with LibreOffice Version: 4.2.0.0.alpha0+
Build ID: 784cfa382be438240dfc936b7551c5012aada9ae.

Samo on Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)