Bug Hunting Session
Bug 54267 - Adding diacritical marks causes havoc when editing (Hebrew, RTL)
Summary: Adding diacritical marks causes havoc when editing (Hebrew, RTL)
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 53312
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 14:40 UTC by skadish1
Modified: 2015-05-25 11:51 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Hebrew with diacritical points. (21.27 KB, application/vnd.oasis.opendocument.text)
2012-08-30 14:40 UTC, skadish1
Details
Screenshot of Hebrew Diacritics error with extra spaces highlighted (50.48 KB, image/png)
2012-09-07 05:22 UTC, Aharon Varady
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skadish1 2012-08-30 14:40:54 UTC
Created attachment 66340 [details]
Hebrew with diacritical points.

Hi, I just upgraded from 3.5 to the 3.6.1 release.

LibreOffice has always had fantastic visual support for unicode languages that include diacritical marks within letters.

But now the following occurs: I open a document full of diacritical points, and everything is initially displayed correctly. But when I edit the document and add new diacritical points to the letters and words, it causes an unwarranted space to occur, or letters to appear doubled, and sometimes the following lines to appear incorrectly indented (by a space of about a single letter).

In the attached document I have not touched the first paragraph, and everything appears normal and correct. But in the second paragraph I have edited the text by adding diacritical points in a number of places and the following things occur:

Second paragraph:
Line 2 (mark added above letter) >> Unwarranted space.
Line 3 (mark added above letter) >> Unwarranted space.
Line 4 (mark added above letter) >> Unwarranted space.
Line 5 (mark added below letter) >> "Doubling" of the first letter (seems to partially hover over itself) followed by unwarranted space.
Line 6 (mark added above letter) >> Unwarranted space, plus the next line appears indented by the space of about one letter.
Line 8 (mark added above letter) >> Letter appears bold or closely doubled plus followed by unwarranted space.
Comment 1 skadish1 2012-08-30 14:43:05 UTC
I forgot to add that this exact kind of problem used to occur with much older versions (either OpenOffice or very early LibreOffice). Or maybe it was even older versions of MS Word, I can't remember. In any case it isn't something entirely new.
Comment 2 skadish1 2012-09-05 19:10:28 UTC
In the meantime I've reverted to Google Docs, because LO is no longer usable. Is there any positive way to draw feedback on this bug?
Comment 3 Urmas 2012-09-06 22:58:17 UTC
Bug 53312?
Comment 4 Aharon Varady 2012-09-07 05:14:14 UTC
I can confirm that I am also seeing this on my new install of LibreOffice 3.6.1.2
Comment 5 Aharon Varady 2012-09-07 05:22:29 UTC
Created attachment 66762 [details]
Screenshot of Hebrew Diacritics error with extra spaces highlighted

This is a screenshot of the errors described by skadish in his bug report.
Comment 6 Urmas 2012-09-07 10:14:35 UTC

*** This bug has been marked as a duplicate of bug 53312 ***
Comment 7 Lior Kaplan 2012-11-10 13:40:49 UTC
I'm reopening this issue, as I'm not sure it's a duplicate of bug 53312. And in any case, the bug here is more detailed and has a test document.

I was able to reproduce the bug, but it had very minor effect (Keter YG font). Would be good to have instructions to reproduce as in the attached screen shot by Aharon.
Comment 8 skadish1 2012-11-24 18:01:24 UTC
Hi Lior, I'm not sure what can be added regarding instructions to reproduce. When you open a previously produced document it looks fine, but then when you start adding new niqqud it starts acting as described.

However, I did notice something unusual recently which maybe contains a clue: At my workplace there is only MS-Office. When I recently edited a document in Office and then opened it later in LibreOffice the problem happened (doubling upon opening the document, even before editing and even using LO 3.5 which normally doesn't cause this problem). That was using ODT. However, I then tried editing the same file converted to DOC and it worked fine both in MS-Office and LibreOffice.
Comment 9 Maxim Monastirsky 2013-08-06 06:55:22 UTC
I can reproduce this bug with LO 4.0.4.2, but not with LO 4.1.0.4 (both on Windows 7 32-bit), so maybe it's already fixed. Can someone else confirm that please?
Comment 10 sarkipo 2014-01-22 20:50:14 UTC
Hi,

I have been having this bug since for a few years, since some version of OpenOffice. Very annoying. I have to work with phonetic transcriptions of all kinds, this bug is a major thing stopping me from throwing MS Office away altogether. Also I seem to have seen it reported to be fixed at some time, but alas, it is quite vivid. Currently on Win7, LO 4.0.22.
Comment 11 sarkipo 2014-01-22 21:11:49 UTC
Seems to be fixed in LO 4.1.4!
Comment 12 sarkipo 2014-03-24 16:12:21 UTC
Sorry to say, but it is NOT fixed in 4.1.4 and in 4.2.2.1.
Comment 13 Joel Madero 2014-11-06 00:17:32 UTC
There are mixed results here - moving back to UNCONFIRMED to get QA team to look at it to both confirm and ensure it's not a duplicate. Thanks
Comment 14 tommy27 2015-05-22 02:25:36 UTC
@sarkipo
please give an update of the bug current status with latest LibO 4.4.3.2 release
Comment 15 Buovjaga 2015-05-25 11:36:27 UTC
Installed Keter YG from http://culmus.sourceforge.net/taamim/
Pasted more characters into document.
Compared document with screenshot and I don't have extra spaces or doubling chars.

Closing as WFM.
Original reported can set back to UNCONFIRMED, if they still see the problems.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b9630867d17c01ec41f6461b1e96288f3932248c
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-25_00:45:41
Locale: fi-FI (fi_FI)
Comment 16 Eyal Rozenberg 2015-05-25 11:51:05 UTC
Verifying - LO Writer 4.4.3.2 on Win7 64bit with Keter YG.