Bug 54340 - SLIDESHOW: PowerPoint slideshow transitions don't automatically advance
Summary: SLIDESHOW: PowerPoint slideshow transitions don't automatically advance
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2012-08-31 22:11 UTC by Tom Williams
Modified: 2015-06-13 22:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

A sample PowerPoint slideshow which demonstrates the misbehavior (2.87 MB, application/vnd.ms-powerpoint)
2012-08-31 22:11 UTC, Tom Williams

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Williams 2012-08-31 22:11:04 UTC
Created attachment 66422 [details]
A sample PowerPoint slideshow which demonstrates the misbehavior

Problem description: 

Steps to reproduce:
1. Open the attached PowerPoint slideshow
2. The slideshow will start and music will play
3. The slideshow will NOT automatically advance and the viewer must click each slide to advance the slideshow.

Current behavior:
The slideshow doesn't automatically advance.

Expected behavior:
The slideshow should automatically advance.

Platform (if different from the browser): 
Windows XP Home Edition (SP3)
Comment 1 Florian Reisinger 2013-04-16 13:21:22 UTC
Can't confirm with Version (Build ID: 84102822e3d61eb989ddd325abf1ac077904985) @Win 7 x64
Comment 2 Tom Williams 2013-04-16 13:36:43 UTC
Ok, I tried this using LibreOffice Version (Build ID: 400m0(Build:2)) on Ubuntu 12.10 Linux (64-bit) and the incorrect behavior happens but slightly differently.  I get the first slide with no music.  Then, when I click that slide, I get a music chart in the lower left corner of the screen and then the first slide transition eventually happens.  On the second slide, nothing happens until I click.  When I click, text appears in the upper left corner of the screen.  If I click again, the transition to the next slide occurs.

If I click each slide manually, I can advance through the slideshow.

Again, this is using:

LibreOffice Version (Build ID: 400m0(Build:2)) on Ubuntu 12.10 Linux (64-bit)

Comment 3 Tom Williams 2013-04-16 13:37:22 UTC
I will try this using LibreOffice 4.0.2 on Windows XP later today.
Comment 4 Tom Williams 2013-04-17 14:20:54 UTC
Ok, last night, I tried this on the original Windows XP Home Edition (SP3) system on which I first encountered this problem.  The problem remains.  I open the attached slideshow and the first slide appears with music and just sits there until I start clicking.  Here is the LibreOffice version I used this time:

Version (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)

Comment 5 ign_christian 2013-06-02 02:14:24 UTC
Confirmed, reproducible on LO (Win7 32bit) same as comment 4
Comment 6 Brian Hicks 2013-10-13 05:14:01 UTC
This is still happening with Impress in version (Build ID: 410m0(Build:2)).

I'm running Ubuntu 12.04 LTS, 64-bit Intel

I can't seem to find a workaround...

Comment 7 Robinson Tryon (qubit) 2014-04-11 18:07:38 UTC
I've gotten reports of a similar problem when testing with LO + OSX 10.7.5:

Presentations created in LO and saved as PPS/PPTX do not respect the Advance "Automatically after..." feature. Regardless of the # of seconds specified, the slide immediately advances. There is no such problem when the presentation is saved as ODP.
Comment 8 Tom Williams 2014-04-27 04:11:56 UTC
I'm able to reproduce this in LibreOffice Impress on Ubuntu 14.04 Linux.
Comment 9 QA Administrators 2015-06-08 14:41:44 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 10 Tom Williams 2015-06-10 07:50:38 UTC
Ok, I tested this in Impress 4.4.3 on Windows XP and the slideshow behaves as expected.  Great job!

In Impress 4.4.3 on Ubuntu Linux 15.04, the slideshow advances past the first slide by itself and then no longer advances.  The music still plays.  Additionally, the text on the second slide never appears.

So, in Impress 4.4.3 on Windows, everything looks fine.  In Impress 4.4.3 on Ubuntu Linux, the slideshow doesn't play properly.

Comment 11 Tom Williams 2015-06-10 07:51:17 UTC
I'm sorry, I tried it in Impress on Ubuntu 15.04, not 4.4.3.