Download it now!
Bug 54420 - FILESAVE: Incorrect .docx exporting to .odt
Summary: FILESAVE: Incorrect .docx exporting to .odt
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 54931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-03 08:07 UTC by Sergey
Modified: 2016-04-30 19:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots: docx1 & docx2 - original files in libreoffice. odt1 & odt2 - result files in libreoffice (574.75 KB, application/x-gzip)
2012-09-03 08:07 UTC, Sergey
Details
Another test file with corrupted formulas (160.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-09 17:38 UTC, Ruslan Kabatsayev
Details
"Another test case" after saving as odt (158.48 KB, application/vnd.oasis.opendocument.text)
2013-01-09 17:39 UTC, Ruslan Kabatsayev
Details
My testkit (1015.46 KB, application/x-zip-compressed)
2013-04-21 14:49 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2012-09-03 08:07:43 UTC
Created attachment 66531 [details]
Screenshots: docx1 & docx2 - original files in libreoffice. odt1 & odt2 - result files in libreoffice

Problem description:
When you open .docx file and than saving to .odt the result file is incorrect (looks different in libreOffice from original in libreOffice). It's not the issue of incorrect reading of .docx (the .docx file itself doesn't consist these errors). For example: instead of one picture in new file I see several and in original file I see only one picture. Some tables have only a part of columns in new file. In original I see all columns in tables

Steps to reproduce:
1. Open .docx file with tables and pictures
2. Save it in .odt
3. Open a new .odt. You'll see incorrect file

Current behavior:
After exporting to .odt the result file looks different from original that was also opened in libreOffice

Expected behavior:
After saving in .odt the result file should look the same as .docx in libreOffice
Comment 1 Jean-Baptiste Faure 2012-09-16 10:27:29 UTC
Problem with duplicate pictures is probably the same as the one described in bug 54931.
Comment 2 Sergey 2012-09-16 16:36:03 UTC
The bug <A HREF="https://www.libreoffice.org/bugzilla/show_bug.cgi?id=54931">54931</A> is only about pictures. Current one is also about tables.
Comment 3 Sergey 2012-09-16 16:40:05 UTC
*** Bug 54931 has been marked as a duplicate of this bug. ***
Comment 4 Ruslan Kabatsayev 2013-01-09 17:38:13 UTC
Created attachment 72735 [details]
Another test file with corrupted formulas

This document has some formulas on pages 7 and 8, which after document saving to odt format and reopening show up as "Object 2" and the like, though some of them are rendered correctly.
In LibO 3.6.0.2 also the images are duplicated at the top of the document.
Image duplication doesn't reproduce on Version 4.1.0.0.alpha0+ (Build ID: 241ccc2568dd685d224f8a2b051c3e3a018d940).
Comment 5 Ruslan Kabatsayev 2013-01-09 17:39:21 UTC
Created attachment 72736 [details]
"Another test case" after saving as odt

Here's result of saving "Another test case" to odt in Version 4.1.0.0.alpha0+ (Build ID: 241ccc2568dd685d224f8a2b051c3e3a018d940).
Comment 6 Florian Reisinger 2013-04-21 14:46:14 UTC
WFM with Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) on Win7 x64
Comment 7 Florian Reisinger 2013-04-21 14:49:15 UTC
Created attachment 78293 [details]
My testkit

Sorry, can confirm. Problem occors when saving as formulas are accurate when opening docx...
Comment 8 QA Administrators 2015-03-16 23:08:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 9 Buovjaga 2015-03-31 08:27:30 UTC
(In reply to Florian Reisinger from comment #7)
> Created attachment 78293 [details]
> My testkit
> 
> Sorry, can confirm. Problem occors when saving as formulas are accurate when
> opening docx...

Only problem I see is that formulas on pg 7 & 8 have slightly different formatting (matching 4031.pdf) affecting how the lines flow etc.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 10 tommy27 2016-04-16 07:22:39 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 11 Jean-Baptiste Faure 2016-04-30 19:07:21 UTC
Original bug report: no test file provided then nothing to reproduce.
Other test files: works as expected for me with current master. built at home under Ubuntu 16.04 x86-64.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF