Download it now!
Bug 54422 - zoom slider doesn't check for button press event
Summary: zoom slider doesn't check for button press event
Status: RESOLVED DUPLICATE of bug 47577
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 08:22 UTC by Morten Leikvoll
Modified: 2014-02-06 20:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Leikvoll 2012-09-03 08:22:24 UTC
Problem description: 
This irritation happens to me too often when editing my wide spreadsheets where I use horizontal scroll frequently. A click release over the zoomtool (wich is near the end of scrollrange) causes changes in zoom ratio.

Steps to reproduce:
1. Scroll spreadsheet to left by LMB clicking on scrolltab and hold mousebutton while dragging.
2. Release mousebutton "accidentially" over the zoom tool nearby the end of the scrolltab.

Current behavior:
Spreadsheet changes zoom ratio when you just meant to scroll.

Expected behavior:
End of scroll only. Only when clicking (and holding) the zoomtool it should change zoomfactor.

Platform (if different from the browser): 
LibreOffice 3.5.6.2 
Build ID: e0fbe70-5879838-a0745b0-0cd1158-638b32
              
Browser: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
Comment 1 [REDACTED] 2013-02-09 07:39:32 UTC
I can confirm this bug exists in Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

It took me a while to work out why this was happening and caused a lot of confusion.

This bug is easyily encountered for anyone using spreadsheets with multiple sheets/pages.

In fact, this occurs when clicking anywhere else on the page and then releasing over the zoomtool. As Morten said, the zoom tool should only activate if the user has first clicked on the zoomtool itself
Comment 2 almos 2013-04-16 19:52:33 UTC
Changed title and component to better reflect the cause of the problem. It doesn't only affect Calc, but all LO components.

LO 4.0.2.2 from Debian Experimental.
Comment 3 Jorendc 2014-02-06 20:38:25 UTC
Looks like a dupe of bug 47577. Lets mark it as such.

*** This bug has been marked as a duplicate of bug 47577 ***