Download it now!
Bug 54430 - FILEOPEN table missing loading a .doc
Summary: FILEOPEN table missing loading a .doc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 10:22 UTC by Sebastian@SSpaeth.de
Modified: 2015-04-27 16:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document received from WinWord users (212.00 KB, application/msword)
2012-09-03 10:23 UTC, Sebastian@SSpaeth.de
Details
Comparison WinWord Libreoffice (213.98 KB, image/png)
2013-11-12 13:30 UTC, Sebastian@SSpaeth.de
Details
bt on a specific console trace (16.99 KB, text/plain)
2013-11-13 20:50 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian@SSpaeth.de 2012-09-03 10:22:48 UTC
Loading the attached .doc, you will not see a lot on p.3. Opening the same file in WinWord will show a not complex-table on p.3 as it should.

There are numerous table-related bugs, but filing this nonetheless as a) there is a test document attached, and b) there was no bug about tables simply gone missing when loading a .doc.

This is with Debian's LibreOffice 3.5.4.2.
Comment 1 Sebastian@SSpaeth.de 2012-09-03 10:23:33 UTC
Created attachment 66536 [details]
Test document received from WinWord users
Comment 2 A (Andy) 2012-12-26 22:57:18 UTC
reproducible with LO 3.6.4.3. (Win7 Home, 64bit)

In LO 3.6.4.3. you can not see the whole table on page 3 while you can see it in WORD 2007.
Maybe this also depends on the page break before this page?

In addition, the characters and graphics in the header and footer are grey in WORD 2007 while they are black in LO.
Comment 3 Julien Nabet 2013-11-11 22:30:08 UTC
On pc Debian testing x86-64 with 4.1.2.3 Debian package, I see a table 1 row 2 cols at page 3.

Sebastian: could you give a new try with a recent LO version and tell us if you can see the table as it should?
If not could you attach a screenshot from MsWord to know what it should look like?
Comment 4 Sebastian@SSpaeth.de 2013-11-12 13:30:29 UTC
Created attachment 89086 [details]
Comparison WinWord Libreoffice

Just retested the file on Libreoffice 4.1.2.3. It still does not load the table. See attached screenshot with a comparison of page 3 as loaded by WinWord and by Libreoffice. The full table is missing, basically.
Comment 5 Julien Nabet 2013-11-13 06:38:06 UTC
Thank you for your feedback Sebastien, following your attachment and the fact I don't see this table, I put it at NEW
Comment 6 Julien Nabet 2013-11-13 20:50:13 UTC
Created attachment 89160 [details]
bt on a specific console trace

On pc Debian x86-64 with master sources updated today, I still don't see this table but noticed this console trace:
Trying to resize readonly stream by seeking, could be a wrong offset!

So I attached the corresponding bt.
I don't know if it may be related.
Comment 7 Julien Nabet 2013-11-13 20:52:30 UTC
Miklos: we've got a png showing a comparison between Word and LO + bt on a specific trace. Any idea what could help here? (I've got a full debug build with master sources updated today so if I can help to test something, no problem).
Comment 8 QA Administrators 2015-04-19 03:20:32 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 9 Gordo 2015-04-27 16:23:04 UTC
With Non-printing Characters on, the table is visible.  The table is within a frame that is anchored to a paragraph that has a hidden character.  Tools -> Options -> LibreOffice Writer -> Formatting Aids -> Hidden text needs to be checked in order to see it.

Still doesn't look right.  The table with "Note:" does not appear at the bottom but overlaps with the other one.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6

Changed to RESOLVED WORKSFORME.