Bug 54481 - EDITING: inconsistant label reference
Summary: EDITING: inconsistant label reference
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Cell-Reference
  Show dependency treegraph
 
Reported: 2012-09-04 07:32 UTC by Morten Leikvoll
Modified: 2021-07-12 10:13 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Leikvoll 2012-09-04 07:32:40 UTC
Problem description: 
When working with identical local labels in several sheets, copy and paste across the sheets messes up label consistancy really bad.

Steps to reproduce:
1. On sheet1 fill cells with exact data shown in square brackets:
 A1:[ACOL]
 B1:[BCOL]
 A2:[="S"&SHEET(A2)&"."&A$1&".R"&ROW(A$1)]

2. Do the same on sheet2

3. Add label ranges for both sheets with insert->names->labels
These entries should be in the label table:
$Sheet1.$A$1:$B$1
$Sheet2.$A$1:$B$1

4. Write [=ACOL] (no quotes) in C2 of sheet1. Watch cell content contain [='ACOL'] and cell showing [S1.ACOL.R1]

5. Copy the entire C2 (using ctrl-c, ctrl-v) to same position in sheet2 and watch it contain the same [='ACOL'] and showing the same [S1.ACOL.R1]. Note that this is not expected. It should show S2...

6. Now TYPE ='ACOL' in the same cell and watch it now display correctly "S2.ACOL.R1". This inconsistancy is locked and invisible by reading the cell content, and apparently the only way to get it right is to type cell content or copy and paste from same page.

LibreOffice 3.5.6.2 
Build ID: e0fbe70-5879838-a0745b0-0cd1158-638b327

Platform (if different from the browser): 
Browser: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
Comment 1 Sören 2012-12-27 19:44:06 UTC
I can confirm the problem in
Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
on Ubuntu 12.04 (x86)
Comment 2 QA Administrators 2015-01-05 17:51:28 UTC Comment hidden (obsolete)
Comment 3 Morten Leikvoll 2015-01-06 09:02:49 UTC
Retested. Still present in 4.2.8.2 (Build ID: 48d50dbfc06349262c9d50868e5c1f630a573ebd)
Tested on Windows 7 Professional, sp1.
Comment 4 Morten Leikvoll 2015-01-07 08:44:33 UTC
Also confirmed bug present in 4.3.5.2 Build ID 3a87456aaa6a95c63eea1c1b3201acedf0751bd5

Tested on Windows 7 Professional, sp1.
Comment 5 QA Administrators 2016-01-17 20:02:56 UTC Comment hidden (obsolete)
Comment 6 Morten Leikvoll 2016-01-18 09:41:12 UTC
Still present in 5.0.4.2
Comment 7 QA Administrators 2017-03-06 14:00:49 UTC Comment hidden (obsolete)
Comment 8 Morten Leikvoll 2017-03-06 14:35:54 UTC
Problem still exists with:

Version: 5.2.5.1
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (nb_NO); Calc: group


Text change of step 3 to help reproduction:

3. Add label range A1:B1 for both sheets with insert->named expressions->labels
Paste "$Sheet1.$A$1:$B$1" into the upper stringedit box, press the Add button.
Then paste "$Sheet2.$A$1:$B$1" [only sheet# is different] into the same box and press the Add button.

After adding these row labels, the listbox should show:
 --- Column ---
 $Sheet1.$A$1:$B$1 [ACOL,BCOL]
 $Sheet2.$A$1:$B$1 [ACOL,BCOL]
 --- Row ---
and nothing more.
Comment 9 QA Administrators 2018-07-10 02:37:05 UTC Comment hidden (obsolete)
Comment 10 Morten Leikvoll 2018-07-10 10:26:13 UTC
Problem persists

Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 8; OS: Windows 10.0; UI render: default; 

The label range definition has been moved to Sheet->Named Ranges and Expressions->Labels..
Comment 11 QA Administrators 2019-07-11 02:54:09 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2021-07-11 03:40:10 UTC Comment hidden (obsolete)
Comment 13 Morten Leikvoll 2021-07-12 10:13:02 UTC
Retested with:
Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (nb_NO); UI: en-US
Calc: threaded

Note:New method to add ranged labels: sheet->named range and expression->manage. You can now have scope to the ranges, and each range gets a name. (The insert->named range and expression menu item now seems redundant, and can not add first range at all)

During this testing, a new bug appears that prevents me from completing this test. I am not able to get a consistant result of =ACOL reference. The order of typing seems to affect the result. If cells A2 contains a string during typing "=ACOL" into C2, the C2 cell will not mirror changes in A2. But if A2 contains empty or number during typing "=ACOL" into C2, it will mirror changes in A2. This may require a new bug report or reference to an existing bug, so I leave the retesting for a future version.