Bug 54513 - Label Horizontal Pitch Not to specific Label dimensions
Summary: Label Horizontal Pitch Not to specific Label dimensions
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-04 22:17 UTC by saltyla1
Modified: 2013-10-16 05:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample document with Avery letter 8160 (9.29 KB, application/vnd.oasis.opendocument.text)
2013-10-03 08:09 UTC, Winfried Donkers
Details
attachment-27611-0.html (5.37 KB, text/html)
2013-10-13 17:14 UTC, saltyla1
Details
attachment-27611-1.dat (1 bytes, multipart/alternative)
2013-10-13 17:14 UTC, saltyla1
Details
avery5160.pdf (841.81 KB, application/pdf)
2013-10-13 17:14 UTC, saltyla1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description saltyla1 2012-09-04 22:17:13 UTC
Problem description: Using Avery 8160 Labels selection
the horizontal pitch was incorrect with only the first
column of labels being in the proper position. This was
repeated with Avery 5167 Labels.
Adjusting the horizontal pitch would only work if the
width was also adjusted causing the print to go off of
the Label or the page width automatically expanding.
The vertical pitch has the same problem.


Steps to reproduce:
1. ....Select, File - New - Labels - Labels Tab -
 Avery Letter size - 8160 Ink Jet Address - Sheet -
 Checkmark the address box - 
 Fill the Label text box with text
Options Tab selection should be, synchronize contents - 
 Entire page
2. ....Press the new document button
3. ....Print the page and compare the widths of the
 columns with that of a sample page of Avery 8160 Labels.

Current behavior:Horizontal pitch of labels falls short
 of Avery 8160 specs. Adjustment is next to futile.
Vertical pitch appeared Ok at least on this Label,
 but Adjustment is futile.

Expected behavior:A printout of the specified Label
 would match the packaged Label sheet.
The Horizontal Pitch would work independently of
 the width.
The Vertical Pitch would work independently of
 the height. 

Platform (if different from the browser): Windows 7
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 tommy27 2013-09-20 18:01:49 UTC
Hi, do you still experience this bug with recent 4.0.5 or 4.1.1 releases?
Comment 2 saltyla1 2013-09-29 21:08:32 UTC
(In reply to comment #1)
> Hi, do you still experience this bug with recent 4.0.5 or 4.1.1 releases?

Yes, partially.
  When using Avery 8160 or 5160 labels,
if I change the Horizontal Pitch to 2.80 and
insure the Page width remains at 8.50 then it
works well.

When using Avery 5267 labels,
if I change the Horizontal Pitch to 2.05 and
change the Top Margin to 0.47 then it
works well.

The problem is I cannot get it to save these values
as the default Avery 8160 or 5160 or 5267 values.

When I press the New Document button on the return
address 5267 labels the font is too large.
When I check mark the address box, and
fill the Label text box with text, maybe it should
have a selected label sized box with a font size only
selection box included.

The Horizontal Pitch, and, also I guess the vertical pitch,
still will increase the page size when the pitch values
are increased. This is ridiculous because the paper
won't stretch. Instead of allowing it to increase
the page size it should just pop up a persistent
warning message and let me continue, while not allowing
printing out side of the selected page size.
It should not change the size of paper that I have
it set at for me.

Thank you,
Brian
Comment 3 saltyla1 2013-09-29 21:22:48 UTC
Yes,
I posted a comment on bugzilla for this for the Windows version 4.0.5.2




________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: saltcher13@yahoo.com 
Sent: Friday, September 20, 2013 11:01 AM
Subject: [Bug 54513] : Label Horizontal Pitch Not to specific Label dimensions
 


 
tommy27  changed bug 54513 

What
Removed
Added
CC    barta@quipo.it  
Comment # 1 on bug 54513 from tommy27  
Hi, do you still experience this bug with recent 4.0.5 or 4.1.1 releases?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 4 tommy27 2013-09-30 01:01:27 UTC
what about Bug 51770? do you think it's the same issue?
Comment 5 Winfried Donkers 2013-09-30 06:07:15 UTC
I will try to reproduce it with version 4. If so, I will see if I can solve the problem (and assign myself to this bug).
(And if it's the same issue as bug 51770, I will mark this bug as a duplicate bug.)
Comment 6 Winfried Donkers 2013-10-01 09:03:30 UTC
@saltcher13:

Hi, I checked Avery (letter size) label 8160 with the manufacturer's specs and they match. The horizontal pitch is 2.75 inch.

With which version of LibreOffice are you working? 
There has been a major change in the label generation code with version 3.6 (https://wiki.documentfoundation.org/ReleaseNotes/3.6) and a smaller change with version 4 (standard labels can be changed and saved, though not with the same (standard) manufacturer/name combination).
It may well be that the problems you report occur with version 3.5.6. That was one of the reasons for the changes in version 3.6.

So far, I haven't been able to reproduce your problem yet (with version 4). If you can give me the most recent version with which you experience your problem (i.e. first column is positioned correctly, other columns are not), it would make it easier for me to investigate.

Thanks!
Comment 7 saltyla1 2013-10-03 00:46:51 UTC
Yes,
  Using version 4.0.5 ,
It is as you said "first column is positioned correctly, other columns are not".
Each subsequent column falls short enough to suspect that it is not
adding the gap between the labels.

I think it may be (not sure) the same as 51770, but with the smaller labels
and more columns the problem is more pronounced resulting from more calculations.

Thanks.
Comment 8 Winfried Donkers 2013-10-03 08:03:15 UTC
(In reply to comment #7)

Bug 51770 is different and has been fixed.
Comment 9 Winfried Donkers 2013-10-03 08:09:41 UTC
Created attachment 87017 [details]
sample document with Avery letter 8160

I have created a document with version 4.0.5.2 and filled it with Avery letter size, 8160.
The horizontal distance between the right column and the middle column is 6.98cm (2.75in) which is as the label definition from Avery.
I have no 8160 labels, so I can't print them, but the document gives no reason to doubt that a print will go wrong.

Not being able to reproduce your problem, could you create and attach a document which shows the problem (i.e. where the horizontal distance between columns is not 2.75 inch)?
Comment 10 saltyla1 2013-10-05 15:19:32 UTC
I measured the labels with my dial calipers and they
were as advertised at 1 x 2 5/8 (2.625).
 It seems that Avery gives dimensions that are rounded and without remainders.
If you add the 2.75 x 3 to 2.75 - 2.625, the result comes short of the
page width of 8.5 .
I found that the calculation for 2.7812 to come near at 8.4998 .

I would think(???&??!) finding the center of the label and subtracting
half of the label size to find the beginning of the label for each
column would be more accurate in this case.

Thank you.
Comment 11 Winfried Donkers 2013-10-09 08:19:33 UTC
(In reply to comment #10)
When calculating the page width from the label dimensions in LibreOffice, I get:
left margin + 2 * hor. dist. + label width + right margin ( not contained in label definition as not all labels are positioned symmetrically, but here aasumed as much as th eleft marging) =
4.8mm + 2 * 69.9mm + 66.7mm + 4.8mm = 216.1 mm = 8.508in.

It cannot be avoided that small differences occur, by rounding, paper shrinking/expanding (moist, temperature), printer inaccurancy/misalignment, etc.
If you maintain a small margin on your label (I mean space between label edge and text), you should allow for these differences.

Your suggestion to place the labels on the page starting from the middle as opposed to starting from the left (which is the current method), is an interesting one. It would certainly be a good idea for labels which are placed symmetrically on the page. But not all labels are like that.
Currently, the right margin is the variable. The right margin cannot be less than 0.
I will think about your suggestion to see if I can find a method whicht spreads the inaccuracy of the label position more evenly over the labels in a row and not incrementing from left to right (current behaviour).
Comment 12 saltyla1 2013-10-13 17:14:52 UTC
Created attachment 87560 [details]
attachment-27611-0.html

In the attachment it shows the difference between 2.75 and 2.80 ensuring no other
settings having been changed for the 5160 label choice. I checked the 8160 label
and it was the same outcome.

I ran the same setup on the other labels I have ( 5267 set at 5167 per avery directions )

and the print was correct.

So, I believe the dimensions that Avery supplied as default for 8160 and 5160 are
incorrect.
This is further supported by the measurements that I made with my dial calipers.

I am sorry that I didn't find this out earlier.
Thank you for your efforts.


________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: saltcher13@yahoo.com 
Sent: Wednesday, October 9, 2013 1:19 AM
Subject: [Bug 54513] Label Horizontal Pitch Not to specific Label dimensions
 


 
Comment # 11 on bug 54513 from Winfried Donkers  
(In reply to comment #10)
When calculating the page width from the label dimensions in LibreOffice, I
get:
left margin + 2 * hor. dist. + label width + right margin ( not contained in
label definition as not all labels are positioned symmetrically, but here
aasumed as much as th eleft marging) =
4.8mm + 2 * 69.9mm + 66.7mm + 4.8mm = 216.1 mm = 8.508in. It cannot be avoided that small differences occur, by rounding, paper
shrinking/expanding (moist, temperature), printer inaccurancy/misalignment,
etc.
If you maintain a small margin on your label (I mean space between label edge
and text), you should allow for these differences. Your suggestion to place the labels on the page starting from the middle as
opposed to starting from the left (which is the current method), is an
interesting one. It would certainly be a good idea for labels which are placed
symmetrically on the page. But not all labels are like that.
Currently, the right margin is the variable. The right margin cannot be less
than 0.
I will think about your suggestion to see if I can find a method whicht spreads
the inaccuracy of the label position more evenly over the labels in a row and
not incrementing from left to right (current behaviour).
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 13 saltyla1 2013-10-13 17:14:52 UTC
Created attachment 87561 [details]
attachment-27611-1.dat
Comment 14 saltyla1 2013-10-13 17:14:52 UTC
Created attachment 87562 [details]
avery5160.pdf
Comment 15 tommy27 2013-10-13 17:36:04 UTC
@saltcher
so basically the error is on Avery side and not LibO's fault?
Comment 16 Winfried Donkers 2013-10-14 06:34:13 UTC
(In reply to comment #12)

> So, I believe the dimensions that Avery supplied as default for 8160 and
> 5160 are
> incorrect.
> This is further supported by the measurements that I made with my dial
> calipers.
> 
> I am sorry that I didn't find this out earlier.
> Thank you for your efforts.
> 

I can change the label definitions in LibreOffice for Avery letter size labels 5160 and 8160, but I would like to get confirmation from someone else that your conclusions are correct. (Nothing peronal, but I don't change the code on unconfirmed bug reports).
Living in Europe, I can't get at Avery letter size labels. I only can download the templates that Avery supplies for the labels, and these templates currently show the same dimensions as the current LibreOffice label definitions.

Let's hope that someone else can confirm your findings.

It's clear that we all want LibreOffice to conform to the actual Avery labels.
Comment 17 Winfried Donkers 2013-10-15 10:59:56 UTC
I just received the label dimensions from Avery Software support:

"Here are the dimensions for Avery product number 5160 or 8160:
TOP MARGIN: 0.5  
SIDE MARGIN: 0.19 
VERTICAL PITCH: 1.   
HORIZONTAL PITCH: 2.75 
LABEL HEIGHT: 1.   
LABEL WIDTH: 2.63 
NUMBER ACROSS: 3 
NUMBER DOWN: 10 
PAGE SIZE: 8.5  x 11.   "

These dimensions are within 0.1mm (0.004in) of the dimensions as used in LibreOffice. Differences are caused by rounding because the dimensions are stored in metric units. These differences are not noticeable to users, they're too small.

My conclusion is that there is nothing wrong with LibreOffice.

@Saltcher13:
I can only recommend that you get in touch with Avery support and tell them that you have label sheets that differ in dimension from what they ought to be.

Marking this bug as resolved now.

(I'm curious what Avery says abou this 2.75 / 2.80in pitch matter, though.)
Comment 18 saltyla1 2013-10-16 02:30:39 UTC
Here then, 
Avery has exposed themselves.
The batteries for their calculator went dead,
and they just guessed!

Even though it is not a bug of LibreOffice,
it could leave a bad impression on the user.
If it was just this one label, it may not be much
of a problem.
You/we may be waiting a long time if we wait
for Avery to make it right.


I mentioned this in a previous post, but did not
provide the actual numbers.

Based on the numbers that Avery just gave you,
this calculation should be made.

Total label width, that is label width times 3 labels
on the page.
Page width minus Total label width, then divide by
the total amount of gaps between the labels and the
margins. There are 4.
Add this to a single label width to get the
horizontal pitch.

Here it is.

2.63 x 3 = 7.89
8.5 - 7.89 = .61
.61 / 4 = .1525
2.63 + .1525 = 2.7825

Horizontal Pitch = 2.7825

I suppose you could script this formula and find
out how many other labels dims are off.

Thanks.


________________________________
from Winfried Donkers  
I just received the label dimensions from Avery Software support: "Here are the dimensions for Avery product number 5160 or 8160:
TOP MARGIN: 0.5  
SIDE MARGIN: 0.19 
VERTICAL PITCH: 1.   
HORIZONTAL PITCH: 2.75 
LABEL HEIGHT: 1.   
LABEL WIDTH: 2.63 
NUMBER ACROSS: 3 
NUMBER DOWN: 10 
PAGE SIZE: 8.5  x 11.   "
Comment 19 Winfried Donkers 2013-10-16 05:54:20 UTC
(In reply to comment #18)
> Based on the numbers that Avery just gave you,
> this calculation should be made.
> 
> Total label width, that is label width times 3 labels
> on the page.
> Page width minus Total label width, then divide by
> the total amount of gaps between the labels and the
> margins. There are 4.
> Add this to a single label width to get the
> horizontal pitch.
> 
> Here it is.
> 
> 2.63 x 3 = 7.89
> 8.5 - 7.89 = .61
> .61 / 4 = .1525
> 2.63 + .1525 = 2.7825
> 
> Horizontal Pitch = 2.7825
> 
> I suppose you could script this formula and find
> out how many other labels dims are off.
> 
> Thanks.

Thank you for your suggestion. It looks good, and probably is for some labels, but unfortunately, labels are not necessarily spread evenly on the page. Left and right margin may differ from the gap between labels and the left margin may differ from the right margin. I checked most of the 1750+ labels in the LibreOffice label wizard and found out the hard way that your suggestion will not work on all labels.
I can only advise to use a margin in the label itself (i.e. start the text a bit left from the border). This margin will adsorb misalignment and small differences in actual label positioning.