Bug Hunting Session
Bug 54653 - FORMATTING: Incorrect spacing in multiline right justified cells
Summary: FORMATTING: Incorrect spacing in multiline right justified cells
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-07 20:41 UTC by Chris Evans
Modified: 2015-03-08 20:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
See the title rows for the formatting mistakes (200.48 KB, image/jpeg)
2012-09-07 20:41 UTC, Chris Evans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Evans 2012-09-07 20:41:08 UTC
Created attachment 66813 [details]
See the title rows for the formatting mistakes

Problem description: 
In cells with autowrap set that are right justified any rows that end with a space show the space at the end of the row.

eg:

      cell |    cell |
description| contents|

Steps to reproduce:
1. Set cell to autowrap
2. set cell to right justified
3. enter data with spaces in 

Current behavior:
As above

Expected behavior:
Spaces at end of rows not showing

Platform (if different from the browser): 
Windows XP SP3
              
Browser: Chrome/21.0.1180.89
Comment 1 A (Andy) 2012-12-27 09:38:18 UTC
Reproducible with LO 3.6.4.3. (Win7 Home, 64bit), but I do not think that this is a bug, because for the example "cell description" you have a character (= space) between the two words.  If wrap automatically is activated then the text will be wrapped after the space and if it is right aligned, then that space will be kept and leads to this example in the attachment.
Discussed can maybe if in such a case the text should already be wrapped before the space.  But it could be that there are reasons against breaking the general rule of the taking into account a space as a normal character.
Comment 2 Sören 2012-12-27 20:05:09 UTC
A bit surprising I could not reproduce the behavior in
Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
on Ubuntu 12.04 (x86)
so it might be fixed/changed in LO 4.0 (or be OS-dependent).
Comment 3 Jorendc 2013-01-27 20:52:00 UTC
I can reproduce this behavior, therefore I mark this as NEW.

As long as no core developer looked at this bug, we don't know or this is correct behavior or not. Therefore I don't close this bug yet.

Following [1] I mark this as 'minor medium'.

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 4 Jorendc 2013-01-27 20:54:11 UTC
@Eike, Markus and Kohei: following https://wiki.documentfoundation.org/FindTheExpert I think you are the appropriate developers to determine this is a bug/notabug or an enhancement.

Thanks in advance,
Joren
Comment 5 Eike Rathke 2013-01-28 20:28:40 UTC
I can't reproduce this, neither in master nor in 4-0-0
Comment 6 QA Administrators 2015-02-19 15:51:07 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 7 Buovjaga 2015-03-08 20:11:43 UTC
No repro -> WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI