Bug Hunting Session
Bug 54717 - FILESAVE: vertical text became horizontal when saving in MS 2000/xp (.doc) format
Summary: FILESAVE: vertical text became horizontal when saving in MS 2000/xp (.doc) f...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-10 09:11 UTC by fazzi
Modified: 2015-02-20 09:59 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
original document with vertical text in odt format (9.42 KB, application/vnd.oasis.opendocument.text)
2012-09-10 09:19 UTC, fazzi
Details
the same document in MS 2000/XP (.doc) format (9.00 KB, application/msword)
2012-09-10 09:21 UTC, fazzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fazzi 2012-09-10 09:11:49 UTC
Problem description: 

Steps to reproduce:
1. open a new document
2. create a table
3. write a VERTICAL text in a cell of the table
4. save in "Microsoft Word 97/2000/XP/2003 (.doc) format
5. close the document
6. reopen the document: now the text is horizontal!

Current behavior:
vertical text became horizontal when saving in MS 2000/xp (.doc)  format

Expected behavior:
the text should remain vartical as happen when I save in .odt format

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0 Iceweasel/15.0
Comment 1 fazzi 2012-09-10 09:19:52 UTC
Created attachment 66908 [details]
original document with vertical text in odt format
Comment 2 fazzi 2012-09-10 09:21:23 UTC
Created attachment 66909 [details]
the same document in MS 2000/XP (.doc) format

the vertical text has become horizontal!
Comment 3 Brenda Granados 2013-02-18 15:44:19 UTC
I have confirmed this behavior using LibreOffice Version 4.0.1.0+ (Build ID: 3e8af168ca227529b752abb9c7aecc42be4a229) and LibreOffice 4.0 on Ubuntu 12.04.

This problem also occurs when the text is changed back to vertical in the .doc file. 

1. Highlight text.
2. Format -> Character
3. Click the position tab.
4. Change to 90 degrees.
5. Save and close the document.

When you reopen the .doc after making the change, that character position setting is back to 0 degrees, horizontal.

This behavior does not occur when the text is not inside a table.
Comment 4 QA Administrators 2015-02-19 15:48:30 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 fazzi 2015-02-20 09:59:06 UTC
In the current Libreoffice version 4.4.0.3 on Debian Linux amd64
the bug is solved.