Bug 54742 - [RFE] [FORMATTING] Shift+F3 (cycle case) working at beginning and end of a word too
Summary: [RFE] [FORMATTING] Shift+F3 (cycle case) working at beginning and end of a wo...
Status: RESOLVED DUPLICATE of bug 63259
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 83439 (view as bug list)
Depends on:
Blocks: Character CaseCycling
  Show dependency treegraph
 
Reported: 2012-09-10 17:40 UTC by
Modified: 2022-05-25 17:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2012-09-10 17:40:28 UTC
It would be desirable if the uppercase and lowercase rotation (Shift+F3) would work too if the text cursor is at the beginning or end of a word, and not only if it is in the middle.
Comment 1 A (Andy) 2013-02-23 22:06:36 UTC
not reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

@Kü: Does this issue still persist for you with the latest release of LibreOffice?

Can anybody else confirm this issue?
Comment 2 Urmas 2013-02-24 03:31:24 UTC
Confirmed in master from 14.02 in Windows.
Comment 3 2013-02-24 07:32:36 UTC
I tried again with 4.0.1 RC1 and it is the same as before:

If I'm directly in front of the first letter of a word or directly behind the last letter of a word, Shift+F3 do'nt work for me (in German).

If I'm in the middle (behind the first letter of a word till in front of the last letter of a word) it works for me.

(The last I posted the Bug I tried with Win 7 64-bit, now with Debian Linux X86.)
Comment 4 A (Andy) 2015-02-13 10:41:39 UTC
Reproducible with LO 4.4.0.3, Win 8.1
Comment 5 d.desire 2015-08-05 15:16:58 UTC
problem exits still
Comment 6 stragu 2021-12-15 12:55:39 UTC
Reproduced with:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 06ac18e6302d666c363740644a7976e8c22d1113
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 7 stragu 2021-12-15 13:12:25 UTC
*** Bug 83439 has been marked as a duplicate of this bug. ***
Comment 8 Justin L 2022-05-25 17:17:37 UTC

*** This bug has been marked as a duplicate of bug 63259 ***