Bug 54831 - Custom (and other) properties not saved to MS XML formats
Summary: Custom (and other) properties not saved to MS XML formats
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-13 00:43 UTC by tom
Modified: 2016-10-12 00:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tom 2012-09-13 00:43:34 UTC
When saving a file to MS XML format (tested with .docx and .xlsx) properties are removed from the document.

Steps to reproduce:

1. Create new spreadsheet
2. File > Properties > Custom Properties
3. Add new custom property
4. Save file as test.xlsx
5. Click 'Use Microsoft Excel 2007/2010 XML Format'
6. Quit LibreOffice
7. Open test.xlsx
8. File > Properties > Custom Properties
9. Observe missing properties
Comment 1 A (Andy) 2012-12-27 20:17:04 UTC
reproducible with LO 3.6.4.3. (Win7 Home, 64bit)
Comment 2 philip.louw 2013-06-27 08:22:01 UTC
Reproduced with LibreOffice 3.5.7.2 or 4.0.2.2
Also found:
1.  Create spreadsheet with Microsoft Office
2.  Add custom Properties
3.  Save and Exit
4.  Open in LibreOffice edit a cell and save.
5.  This clears all Custom Properties
Comment 3 eugen.krizo 2014-11-28 13:40:48 UTC
Reproduced with LibreOffice Writer 4.2.7.2 / Linux Mint
Comment 4 alessio_d 2015-08-11 11:22:12 UTC
Reproduced with LO Calc 4.3.7.2 / Win7 x64
The bug is old, is there any chance that it will be fixed?
Comment 5 QA Administrators 2016-09-20 10:21:54 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920
Comment 6 tom 2016-10-12 00:07:29 UTC
Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Mac OS X 10.12; UI Render: default; 
Locale: en-AU (en_AU.UTF-8); Calc: group

Going through the steps now saves the custom properties.

Note that I can't verify that the exact issue described in [https://bugs.documentfoundation.org/show_bug.cgi?id=54831#c2](Comment 2) has been fixed, as I don't have a copy of MS Office to check with.