Download it now!
Bug 54913 - FORMATTING: Table formatting problems
Summary: FORMATTING: Table formatting problems
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2012-09-14 09:30 UTC by M. Schlegel
Modified: 2017-01-31 09:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (10.46 KB, application/vnd.oasis.opendocument.graphics)
2012-09-14 09:44 UTC, M. Schlegel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M. Schlegel 2012-09-14 09:30:40 UTC
Problem description: 
When trying to change the font properties in multiple table cells, nothing happens. This does not always occur; when creating a new document and a new table, there is no problem. But in the attached document, I'm unable to change the font, its size or its color. It contained multiple tables and images before, it's a stripped down version. I'm not sure after which steps exactly this happens. In the same document I sometimes wasn't able to change the border color, however I'm not able to reproduce this here.


Steps to reproduce:
1. Open the attached ODG file.
2. Highlight several cells of the table and look at the font formatting controls
3. Try to change font formatting. Nothing happens

Current behavior:
When highlighting multiple cells, font/font size/font color controls show the correct formatting, but it is not applied to the actual text.

Expected behavior:
Formatting is applied to the text.

Platform (if different from the browser): 
Tested on Ubuntu 12.04 / Libreoffice 3.6.0.2 and Mac OS X 10.6 / Libreoffice 3.6.1.2
Comment 1 M. Schlegel 2012-09-14 09:44:19 UTC
Created attachment 67146 [details]
Test document
Comment 2 ydutrieux 2012-12-15 19:18:24 UTC
Reproduced with libo Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Comment 3 QA Administrators 2015-01-05 17:51:52 UTC Comment hidden (obsolete)
Comment 4 Wolfgang Jäger 2015-01-20 12:47:24 UTC
Just tested  M. Schlegel's example under 4.5.3.1.

Compared to the original report the behaviour may be changed a bit (not quite sure): 
The font (or character respectively) properties 'Italic' and 'Strikethrough' were editable and applied correctly. 'Overlining' and 'Underlining' as well, this including an explicitly chosen colour and modifications of the style (like 'double', 'bold', 'dotted'). 

Still editable and remembered but not correctly applied were the font properties 'Bold' (including the bold modification of 'Italic') and 'Size'.

The wrong 'Size' applied, "7" in the example, also showed up using the context menue and then the selecting aid 'Size' while it was set to 18 in the formatting dialogue.

Changing the properties under discussion ('Bold', 'Size') on the way over the context menu were correctly applied. They were not taken over by the formatting dialogue. No problem with the other style modifications.

A newly created table in the same document did not show any of these flaws. A strange bug whose fixing, however, my have become obsolete as "historic".
Comment 5 QA Administrators 2016-02-21 08:36:19 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2016-06-14 07:34:07 UTC
Works in 5.2 (selected 3 cells from the right and changed background to green from table/cell properties as well as font size to 12 via sidebar). 

Please double check.
Comment 7 QA Administrators 2017-01-31 00:29:57 UTC Comment hidden (obsolete)
Comment 8 Heiko Tietze 2017-01-31 09:36:46 UTC
(In reply to Heiko Tietze from comment #6)
> Works in 5.2... 
> Please double check.

Closing now as WFM.