Bug 55011 - duplicated picture in LO 3.6.2.1 but not in LO 3.6.3.0+
Summary: duplicated picture in LO 3.6.2.1 but not in LO 3.6.3.0+
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-17 11:54 UTC by Jean-Baptiste Faure
Modified: 2014-10-26 06:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen copy with LO 3.6.2.1 (206.55 KB, image/png)
2012-09-17 11:54 UTC, Jean-Baptiste Faure
Details
screen copy with LO 3.6.3.0+ (190.26 KB, image/png)
2012-09-17 11:55 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-09-17 11:54:47 UTC
Created attachment 67280 [details]
screen copy with LO 3.6.2.1

Steps to reproduce:
1/ open http://wiki.documentfoundation.org/images/4/4f/IG3500-ImpressGuideLO.odt with LO 3.6.2.1 (Build ID: ba822cc) and go to page 7. The LibreOffice logo seems to be duplicated.
2/ open the same file with LO 3.6.3.0+ (Build ID: 5e13c24) build at the branch-off commit : http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-6&id=5e13c24c7d1af9315db9e3abbc1d57fe0e8f1aa5. The logo looks correct.
AFAIK, at this stage there shouldn't be any difference between both builds.

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2012-09-17 11:55:33 UTC
Created attachment 67281 [details]
screen copy with LO 3.6.3.0+
Comment 2 tommy27 2014-10-24 21:51:25 UTC
reproducible under Win7x64 using LibO 3.6.1.2
not reproducible using LibO 4.3.2.2
so RESOLVED WORKSFORME
Comment 3 Jean-Baptiste Faure 2014-10-26 06:46:03 UTC
Hi Tommy
Thank you for checking this bug report again.

It is still reproducible for me with all versions I tested: LO 4.1.6, LO4.2.6.3, LO 4.3.4.0.0+ and LO 4.4.0.0.alpha1+.

But I understood what happens:
1/ the same picture is inserted two times. You can see that if you open the content.xml of the document. graphics444 and graphics445, both use Pictures/10000201000007D0000001FDE3A2A0C3.png
2/ the difference is that graphics444 is anchored to an hidden paragraph.

So if you check the menu entry View > Hidden paragraphs, you should see both pictures.

So the problem is not in LibreOffice, it is in the document.

Closing as NotOurBug ;-)

Best regards. JBF