Bug Hunting Session
Bug 55071 - Array Formulas Do Not Work
Summary: Array Formulas Do Not Work
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-18 19:50 UTC by llatl
Modified: 2015-05-06 09:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Single sheet workbook with example of failed array formulas. (77.50 KB, application/vnd.ms-excel)
2012-09-18 19:50 UTC, llatl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description llatl 2012-09-18 19:50:53 UTC
Created attachment 67353 [details]
Single sheet workbook with example of failed array formulas.

I have an Excel 97-2003 workbook that relies on many array formulas. In Calc 3.3, the formulas worked as expected when I opened the workbook in Calc. In versions 3.5 thru 3.6.2, the formulas do not work.

I have attached a single sheet of the original workbook so that you can see a sample of the problems I'm having. Column J is where the formulas are located. I don't know if my use of the Offset function to dynamically name ranges is part of the problem or not. Still, remember that all my formulas work correctly in Cal 3.3.


Leb
Comment 1 GerardF 2012-09-19 10:11:38 UTC
Since 3.6.0 there is a change with INDIRECT function syntax.

You can no longer use formula like =ROW(INDIRECT("1:"&ROWS(range)))
but you may write complete adresses =ROW(INDIRECT("A1:A"&ROWS(range)))

unles you change the option in :
Tools > Options > LO Calc > Formula > Detail calculation setting
Custom : "Excel A1" instead of "use formula syntax".

I set it to NEW (not WORKSFORME) because i don't know why this change and if this change is really usefull.
Comment 2 jimg 2012-10-18 03:37:02 UTC
another example:

was reviewing an "[excel challenge][1]" and found an question that I can obtain an answer with excel 2003+ but not in LibreOffice Calc 3.5.4.2. I'm interested in why the solution doesn't work in Calc but does in Excel. For question 6:

    =STDEV('Raw Data'!C2:C252/MID('Raw Data'!A2:A252,10,4))

And yes, I understand that it is a CSE formula and entered in the formula with ctrl+shift+enter in both excel and calc. Excel returns a result, Calc returns #DIV/0!.

Saving / reloading the file in xls or ODS has no effect in Calc - and Calc is configured for cells to auto calculate (Tools > Cell Contents > AutoCalculate on) so that isn't the culprit. Also tried (Tools > Options > LO Calc > Formula = ExcelA1) and edited (add space then remove space) & saved (shift-ctrl-enter) without any change.

Any ideas why?

  [1]: http://cl.ly/1g1N0a2b0b0P0M182d07
Comment 3 GerardF 2012-10-18 14:20:10 UTC
Freedesktop is for reporting bug, not for question. Use mailing list for tis.

MID function returns "text" value, use VALUE to convert text in number.

STDV(dara1/VALUE(MID(data2,10,4)))
Comment 4 jimg 2012-10-18 15:54:07 UTC
@GerardF - Thank you for isolating the problem. My point is that excels default is to treat the extracted array elements as numeric, while Calc interprets them as text. Whether Excel or LO Calc is the faulty one is left for individual interpretation, but Excel types will get caught up here.
Comment 5 Joel Madero 2015-05-02 15:40:52 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 6 Luke 2015-05-06 09:18:08 UTC
Tools > Options > LO Calc > Formula > Detail calculation setting
Custom : "Excel A1"

Causes Calc to generate the same results as Excel in Column J. J7:J26 give results, while the rest are #Value

In the second example, SeatGeek Excel Challenge.xls:
=STDEV('Raw Data'!C2:C252/MID('Raw Data'!A2:A252,10,4))

Calc also gives the same results as Excel, #DIV/0!