Download it now!
Bug 55072 - ACCESSIBILITY: Some colors do not follow system theme, and can't be set in preferences
Summary: ACCESSIBILITY: Some colors do not follow system theme, and can't be set in pr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: accessibility
Depends on:
Blocks: a11y-Windows
  Show dependency treegraph
 
Reported: 2012-09-18 20:29 UTC by Jernej Simončič
Modified: 2016-09-13 07:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer screenshot showing white rulers (29.90 KB, image/png)
2012-09-18 20:29 UTC, Jernej Simončič
Details
Writer 4.4.2 in dark high contrast mode (28.91 KB, image/png)
2015-05-02 18:43 UTC, Jernej Simončič
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jernej Simončič 2012-09-18 20:29:46 UTC
Created attachment 67354 [details]
Writer screenshot showing white rulers

Problem description: 

Background colour on the welcome screen and the background of rulers in Writer and Draw appear to be hardcoded to white, and there doesn't seem to be any way to change them.

This seems to have been introduced in 3.6 - I don't remember seeing these problems in 3.5 and earlier.

Steps to reproduce:
1. Set a high-contrast colour scheme in Windows with dark background and bright text
2. Run LibreOffice
3. Create a new text document or drawing

Current behavior:

Background on welcome screen is (nearly) white, background of rulers is white.

Expected behavior:

Colours follow Windows colour scheme.

Also, a suggestion for the colour preferences: include Windows scheme colours in the drop-down selectors.

Platform (if different from the browser): 
              
Browser: Opera/9.80 (Windows NT 6.2; Win64; x64; Edition Next) Presto/2.12.388 Version/12.10
Comment 1 Jan-Peter Rühmann 2013-11-03 14:38:36 UTC
same in Linux
Comment 2 V Stuart Foote 2014-01-20 20:34:09 UTC
@Jernej,

Please review a current build of LibreOffice master 4.3.0.0alpha ( http://dev-builds.libreoffice.org/daily/master/ ), this issue no longer appears to be valid with some recent work done on bug 71511

If it is functioning as it should (I believe it is), please set resolved fixed.
Comment 3 Jernej Simončič 2014-01-20 22:50:06 UTC
I installed build 3f150d2601a5eaec579816bc30a19fc4a446d571, but as far as I can see, the problem is partially still there.

Welcome screen is mostly fixed (the majority uses the system background colour, and green sidebar isn't nearly as annoying as white in 4.1), but the rulers are still white, and I can't find any way to change their colour.

When I opened Writer, it also defaulted to white document background and light-gray background outside the document area, but at least I was able to fix that - it would've helped if the "Color setting" dropdowns in Appearance included Windows' system colours, instead of requiring me to first define them manually in Colors; letting me choose an icon theme other than "High contrast" would've been nice as well (should I open separate bug reports for this?).
Comment 4 V Stuart Foote 2014-01-20 23:09:51 UTC
@Jernej,

Any improvement for you if you navigate to Tools -> Options -> Accessibility: options for high contrast appearance. And check on either the 'Automatically detect high contrast mode of operating system', and maybe also 'use automatic font color for screen display'?
Comment 5 Jernej Simončič 2014-01-20 23:22:54 UTC
I tried both of those options, but they seem to only affect the document background when it's set to Automatic (Application background set to Automatic is still white).
Comment 6 Joel Madero 2015-05-02 15:41:41 UTC Comment hidden (obsolete)
Comment 7 Jernej Simončič 2015-05-02 18:43:02 UTC
Created attachment 115277 [details]
Writer 4.4.2 in dark high contrast mode

As of 4.4.2, the problems I described are mostly fixed.

There's still a problem with the ruler - while it's background now follows the system colour scheme (when "Automatically detect high-contrast mode of operating system" is selected; I still don't know what the other two options do), the colour used for notches is too dark, and the numbers are still black (and thus invisible). See the attached image.

I also noticed a problem in Calc: if "Automatically detect high-contrast mode of operating system" is not selected (and thus document colours should be used), background colours are ignored, and all cells appear white (text colours are applied normally).
Comment 8 Robinson Tryon (qubit) 2015-12-10 03:37:50 UTC Comment hidden (obsolete)
Comment 9 Yousuf Philips (jay) (retired) 2016-09-13 07:34:33 UTC
Yes the ruler was changed in 4.4 by kendy, so lets close this as the initial issue has been solved.

https://wiki.documentfoundation.org/ReleaseNotes/4.4#Changes_to_rulers

Regarding the issue of which colors the ruler elements should take from the theme, there are a few bug reports that are available about that issue (bug 90214, bug 86617).