Bug 55073 - Add more details to the LibreOffice User-Agent string
Summary: Add more details to the LibreOffice User-Agent string
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-18 23:51 UTC by Johnny_M
Modified: 2017-03-03 16:08 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny_M 2012-09-18 23:51:20 UTC
A simple "LibreOffice" string has been entroduced on https://bugzilla.redhat.com/show_bug.cgi?id=678440 But given the changing nature of software implementation - and LibreOffice is no exception here - and for statistical purposes, it would be nice if web developers were able to detect the version of LibreOffice in its User-Agent.
E.g., LibreOffice 3.6.1 uses "LibreOffice/3.6$Windows_x86" as generator meta data when a file is stored in one of the Open Document formats. A similar string could be used as the User-Agent string.
Comment 1 Xisco Faulí 2017-03-02 10:14:08 UTC Comment hidden (obsolete)
Comment 2 Johnny_M 2017-03-03 16:08:55 UTC
I'm closing this after all, because:
- I don't personally have a use for it
- There is a privacy and security implication (disclosure of the LO version and the OS)
- There may be an impact on people using the user agent filtering in their firewall/proxy, as described in https://ask.libreoffice.org/en/question/12565/libreoffice-personas-behind-proxy-firewall/