Bug Hunting Session
Bug 55437 - CRASH FILEOPEN .odt with formulas converted in some steps from particular .DOCX
Summary: CRASH FILEOPEN .odt with formulas converted in some steps from particular .DOCX
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-28 21:53 UTC by ape
Modified: 2013-01-03 14:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message (13.40 KB, image/png)
2012-09-28 21:53 UTC, ape
Details
bt with symbols on master (16.00 KB, text/plain)
2012-10-05 21:35 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2012-09-28 21:53:26 UTC
Created attachment 67840 [details]
Error message

The problem LibO-3.6.2.2(Windows) came to light at proekt_MU.docx (file in an attachment 57754 [details]): 100% departure LibO after following.
1. open proekt_MU.docx;
2. proekt_MU.docx save as proekt_MU.fodt;
3. reload or reopen proekt_MU.fodt;
4. proekt_MU.fodt save as proekt_MU.odt;
5. reload proekt_MU.fodt – crash.
Comment 1 Julien Nabet 2012-09-30 21:17:00 UTC
On pc Debian x86-64 with 3.6 sources updated 2 days ago, I didn't reproduce this.

Rainer: Reading this http://wiki.documentfoundation.org/Release_Criteria#Blocker_Bug_Definition, I don't think it's a blocker but maybe I'm wrong so would like your opinion if you have some time.
Comment 2 Rainer Bielefeld Retired 2012-10-01 05:01:04 UTC
NOT Reproducible with Server Installation of "LibreOffice 3.6.2.2 rc  German UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit), then never again

But:
I opened "proekt_MU.docx" from LibO Start Center File Menu and got Error message: 
Microsoft Visual C++ Runtime Library
Runtime Error!
Program C:\.....\soffice.bin
abnormal program termination

NOT reproducible with Server Installation of  "LibreOffice  3.6.2.0+  English UI/ German Locale [Build-ID:  6781ee7] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time2012-08-31 19:54:09}, own profile

@Julien Nabet: 
I agree, this crash needs too many chin ups, it's not a blocker.

@ape:
Does "proekt_MU1.odt" from attachment 57754 [details] crash reliably for you?
Any Idea what setting or what ever else might be related to aour crashes?
Does the crash persist after having renamed user profile?
Comment 3 Rainer Bielefeld Retired 2012-10-01 05:01:32 UTC
Comment on attachment 67840 [details]
Error message

Correct Mime Type
Comment 4 ape 2012-10-01 07:11:22 UTC
(In reply to comment #2)
> @ape:
> Does "proekt_MU1.odt" from attachment 57754 [details] crash reliably for you?
> Any Idea what setting or what ever else might be related to aour crashes?
> Does the crash persist after having renamed user profile?
--
The error is reproduced on the new clear profile.
Operating system – Windows XP 64-bit, sp2 with Microsoft Office 2007 sp3. Installed all updates.
Several reasons can cause this error:
1. The MSO-12.
2. The use of different assembly environments (for example, MSVCR-2008 and MSVCR-2008 SP1) when compiling files "LibreOffice 3.6.2.2".
3. Use the package MSVCR-2008 SP1 to compile the executable binary files and manifests the information that has been used MSVCR-2008.
Comment 5 ape 2012-10-01 08:00:22 UTC
(In reply to comment #2)
> NOT Reproducible with Server Installation of "LibreOffice 3.6.2.2 rc  German
> UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit),
> then never again
> 
> But:
> I opened "proekt_MU.docx" from LibO Start Center File Menu and got Error
> message: 
> Microsoft Visual C++ Runtime Library
> Runtime Error!
> Program C:\.....\soffice.bin
> abnormal program termination
> 
> NOT reproducible with Server Installation of  "LibreOffice  3.6.2.0+ 
> English UI/ German Locale [Build-ID:  6781ee7] on German WIN7 Home Premium
> (64bit)  {tinderbox: Win-x86@9, pull time2012-08-31 19:54:09}, own profile
--
The file "libreoffice-3-6 ~ 2012-09-24_03.24.57_build_info.txt" says:
«checking for a friendly Microsoft C/C++ compiler installation path... /cygdrive/c/PROGRA~2/MICROS~1.0/VC
checking the Microsoft C/C++ Compiler... found (/cygdrive/c/PROGRA~2/MICROS~1.0/VC/bin/cl.exe)
checking the Version of Microsoft C/C++ Compiler... found compiler version 001500003072 (MSVS 2008)».
This is MSVCR-2008 SP1.
Resources «manifest» (files: quickstart.exe; sbase.exe; scalc.exe; sdraw.exe; simpress.exe; smath.exe; sweb.exe; swriter.exe; soffice.exe and soffice.bin) write:
«checking for a friendly Microsoft C/C++ compiler installation path... /cygdrive/c/PROGRA~2/MICROS~1.0/VC
checking the Microsoft C/C++ Compiler... found (/cygdrive/c/PROGRA~2/MICROS~1.0/VC/bin/cl.exe)
checking the Version of Microsoft C/C++ Compiler... found compiler version 001500003072 (MSVS 2008).»
This is MSVCR-2008.
I think this is the most likely cause. But for testing I would need 2-3 days.
--
If I remember correctly, was used in August to compile-MSVCR-2008 package. Therefore, "tinderbox: Win-x 86 @ 9, pull time2012-08-31 19:54:09" does not have this bug. I think that I discover the error and in various versions of the "Dev-3.7.0.0 LibO".
Comment 6 Julien Nabet 2012-10-05 18:03:48 UTC
Rainer: before requesting Tor, have you succeeded in reproducing it?
Comment 7 Rainer Bielefeld Retired 2012-10-05 19:20:10 UTC
(In reply to comment #6)
@Julien Nabet: I did not find the time today, will try tomorrow and leave a comment here.
Comment 8 Julien Nabet 2012-10-05 21:35:46 UTC
Created attachment 68142 [details]
bt with symbols on master

On pc Debian x86-64 with master sources updated today (+ a brand new LO profile), I reproduced the bug.
Comment 9 Julien Nabet 2012-10-05 21:39:19 UTC
Comment on attachment 68142 [details]
bt with symbols on master

Sorry wasn't on the right bugtracker.
Comment 10 Rainer Bielefeld Retired 2012-10-06 15:14:17 UTC
Still not reproducible with Server-installation of Master "3.7.0.alpha0+  – ENGLISH UI [Build ID: b255de8]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3

May be the report is not clearenough, what might step 3 "reopen or reload" mean? Can't that be decided? Is "Reload" the menu item (But how to do step 5 then?) or simply means "open after having closed"?
Comment 11 ape 2012-10-07 13:05:22 UTC
(In reply to comment #10)
> Still not reproducible with Server-installation of Master "3.7.0.alpha0+  –
> ENGLISH UI [Build ID: b255de8]" {tinderbox: Win-x86@16, pull time 2012-10-06
> 09:31:39} on German WIN7 Home Premium (64bit)
> UserInstallation=$SYSUSERCONFIG/LOdev/3
> 
> May be the report is not clearenough, what might step 3 "reopen or reload"
> mean? Can't that be decided? Is "Reload" the menu item (But how to do step 5
> then?) or simply means "open after having closed"?

You are using the correct Assembly of the package:
checking the Version of Microsoft C/C++ Compiler... found compiler version 001500002102 (MSVS 2008).
This is MS_VCR-2008 (non SP1)
Comment 12 ape 2012-10-07 13:25:08 UTC
I have reproduced the error using this build:
Build Info
tinderbox: administrator: nthiebaud@gmail.com
tinderbox: buildname: W2008R2@20-With-Symbol-Bytemark-Hosting
tinderbox: tree: MASTER
tinderbox: pull time 2012-10-01 05:02:30
tinderbox: git sha1s
core:e12f501bebf83ea8121e517283c25c24587268a7
dictionaries:48ab525dcfd6451fa2f3e37e92bd60f3885c47f7
help:752c24a0d69670fc9577fa4ae4cfac0d3ae00269
This build has a large additional database issues, as it uses Java-7 only.
Comment 13 ape 2012-10-09 08:32:53 UTC
It seems to me, need to raise the status of this bug. Invalid build environment can be the main cause of the birth of this error:
1. All distributions (including 3.5.7.2) in which the error is absent use it:
"checking the Microsoft C/C++ Compiler... found (/cygdrive/c/PROGRA~2/MICROS~1.0/VC/bin/cl.exe)
checking the Version of Microsoft C/C++ Compiler... found compiler version 001500002102 (MSVS 2008)".
2. All distributions (including 3.6.3.0), in which the error is present, use it:
"checking the Microsoft C/C++ Compiler... found (/cygdrive/c/PROGRA~2/MICROS~1.0/VC/bin/cl.exe)
checking the Version of Microsoft C/C++ Compiler... found compiler version 001500003072 (MSVS 2008)".
3. I think that TDF need to assemble a package of LibO-3.6.3.0-beta.msi, using MS_VCR-2008 version 9.0.21022.8.
Comment 14 ape 2012-10-12 08:41:22 UTC
@:_fridrich.strba@bluewin.ch
Fridrich! It may be necessary to change the build environment - "fall back" to "clean" MS_VCR_2008? I think that checking alibis for SP1 is urgently needed, especially given the new error "NEEDINFO" in the tree «LO-dev_3.7.0.0». "nthiebaud@gmail.com" in the tree «W2008R2@16-minimal_build» uses this environment. Maybe that's why it, unlike the branches «W2008R2@20-With-Symbol-Bytemark-Hosting» (it is assembled, but among MS_VCR-2008sp1), there a number of errors. Unfortunately, I can’t find a link to the page of Microsoft, which is written in the code to specify a particular version of MSVCR (i.e. VC90.CRT_9.0.21022.8 or VC90.CRT_9.0.21022.218 or VC90.CRT_9.0.30729. 6161 ...). It is possible that somewhere in the code specifically the version "9.0.21022" - hence the problem.
Sorry, that appealed to You directly to see Your email address in the «build_info_3.6.4.0_win_x86».
Comment 15 ape 2012-10-24 04:42:54 UTC
Version of the MSVCR-9 is not the cause of the error. LibO-Dev_3.7.0.0 (Win-x86@6/master/2012-10-20_14.21.35: <l.lunak@suse.cz>) revised steel bug, although it was built by the MSVCR_9.0.21022.8.
Comment 16 ape 2012-10-24 05:12:27 UTC
(In reply to comment #15)
> Version of the MSVCR-9 is not the cause of the error. LibO-Dev_3.7.0.0
> (Win-x86@6/master/2012-10-20_14.21.35: <l.lunak@suse.cz>) revised steel bug,
> although it was built by the MSVCR_9.0.21022.8.
--
Sorry, I was wrong!
 LibO-Dev_3.7.0.0 (Win-x86@6/master/2012-10-20_14.21.35: <l.lunak@suse.cz>) creates FODT-file. But this file is lost OLE-formula. See bug 56270.
Comment 17 ape 2012-10-24 05:47:47 UTC
(In reply to comment #16)
> ...
>  LibO-Dev_3.7.0.0 (Win-x86@6/master/2012-10-20_14.21.35: <l.lunak@suse.cz>)
> creates FODT-file. But this file is lost OLE-formula. See bug 56270.
--
As I see it, the regression from a decision of another error - converting error in FODT-file, if Microsoft Office is installed with the Equation editor. This error is in LibreOffice-3.5.7.