Bug 55698 - PDF export makes gradient transparent
Summary: PDF export makes gradient transparent
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-06 16:49 UTC by kitaets
Modified: 2013-11-16 16:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Draw document to export (9.59 KB, application/vnd.oasis.opendocument.graphics)
2012-10-06 16:49 UTC, kitaets
Details
Impress document to export (11.52 KB, application/vnd.oasis.opendocument.presentation)
2012-10-06 16:50 UTC, kitaets
Details
PDF exported from Draw document (5.79 KB, application/pdf)
2012-10-06 16:51 UTC, kitaets
Details
PDF from Inkscape (1.81 KB, application/pdf)
2012-10-07 12:41 UTC, kitaets
Details
Inkscape file - circles as in LibO (6.25 KB, image/svg+xml)
2013-08-08 11:38 UTC, kitaets
Details
PDF from Inkscape 2 (circles) (2.88 KB, application/pdf)
2013-08-08 11:40 UTC, kitaets
Details
PDF - LibO export vs Inkscape export in Evince (64.95 KB, image/png)
2013-08-08 11:41 UTC, kitaets
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kitaets 2012-10-06 16:49:23 UTC
Created attachment 68169 [details]
Draw document to export

Shapes with gradients in document exported to PDF become semi-transparent.
If the shape has a shadow the shadow becomes visible behind the shape.

Three attachments: Draw and Impress documents with such shapes (w/o shadows) and PDF created from attached Draw document.

Checked with LibO 3.5.6.2 in Ubuntu 12.04 and standard Ubuntu document viewer Evince.
Comment 1 kitaets 2012-10-06 16:50:26 UTC
Created attachment 68170 [details]
Impress document to export
Comment 2 kitaets 2012-10-06 16:51:03 UTC
Created attachment 68171 [details]
PDF exported from Draw document
Comment 3 Jean-Baptiste Faure 2012-10-07 07:15:01 UTC
Hmmm, you should try with another PDF reader. Evince is not a reference in this field. In other words, bug in LO or in Evince?

Best regards. JBF
Comment 4 kitaets 2012-10-07 07:41:52 UTC
I have also tried PDFedit and online GoogleDocs viewer. It looks the same.
But it looks Ok in Adobe Reader (I just reached Windows PC).
Apparently PDFedit and GoogleDocs uses the same Linux engine as Evince.
Where should I post this bugreport?
Comment 5 Jean-Baptiste Faure 2012-10-07 08:32:41 UTC
You are using Ubuntu, so try on launchpad: https://bugs.launchpad.net/

Closing as NotOurBug. Feel free to reopen if needed.

best regards. JBF
Comment 6 kitaets 2012-10-07 12:40:32 UTC
PDF from Inkscape looks great. And there is a big discussion on Launchpad about this _LibreOffice_ bug (#164233).
Comment 7 kitaets 2012-10-07 12:41:29 UTC
Created attachment 68204 [details]
PDF from Inkscape
Comment 8 tommy27 2013-08-03 17:38:13 UTC
@kitaets
marking it again as NOTOURBUG
this is not a LibO bug but rather an issue of different PDF readers.
Acrobat Reader has no issue with the PDF I generate from your test files.
Comment 9 kitaets 2013-08-07 14:00:06 UTC
@tommy27
As you can see I wrote about Inkscape, that's the reason why I had reopened this bug before. "Different PDF readers" don't have this issue when opening Inkscape-created PDF. Check please.
I believe that someone who can compare those PDFs should say if the one from LibO is corrupted or not. I also believe that this bug should be reopened until someone analyze them.
Please reply.
Comment 10 tommy27 2013-08-08 08:35:54 UTC
@kitaets

you said that PDF export makes gradient semitransparent, however as you said Adobe Reader has no troubles unlike Evince and other readers you tried.

as I said your test files can be exported to PDF with no issue on Windows and displayed correctly in Acrobat Reader (so I'm changing OS to Linux)

so why do you think this is a LibO bug rather than an Evince bug?

I also do not understand your attachement from Inkscape... it has a different picture form other examples so it's not clear to me what it should exactly show.

please attach a screenshot showing differences between the original file and the incorrect PDF you obtain, since in my tests I see no difference between input and PDF output.
Comment 11 kitaets 2013-08-08 11:38:57 UTC
Created attachment 83828 [details]
Inkscape file - circles as in LibO
Comment 12 kitaets 2013-08-08 11:40:23 UTC
Created attachment 83829 [details]
PDF from Inkscape 2 (circles)
Comment 13 kitaets 2013-08-08 11:41:41 UTC
Created attachment 83830 [details]
PDF - LibO export vs Inkscape export in Evince

Screenshot of PDFs - LibO export vs Inkscape export in Evince
Comment 14 kitaets 2013-08-08 11:57:50 UTC
@tommy27
Adobe Reader is not the only one software to view PDF documents. There are a lot of portable devices to read PDFs which can show them incorrectly.
There's no difference if I export the drawing in Linux or Windows. And if I use  Acrobat Reader in Linux it shows the PDF correctly. AR just can manage with a buggy PDF. So it's not about Linux only. And not about Evince - see the screenshot.
I have tried to export the attached Draw file to SVG and it was ridiculous. I haven't attached the result because it's not about PDF. But exporting in LibO is buggy. You can try it yourself.
Comment 15 tommy27 2013-08-08 13:19:03 UTC
well, Adobe Reader is not the only one for sure... however I can tell you that even a very old  AR 7.0 release nicely display the "PDF exported from Draw document" test file and even a Foxit Reader 5.4 does a nice job.

InkScape output seems to be more compatible than LibO output but I'm not sure LibO must be blamed if some PDF reader cannot correctly read what other PDF software read with no trouble.

at least I think it's not LibO 100% fault... 
this is just my opinion.