Bug Hunting Session
Bug 55721 - FILESAVE: Gradient colored charts looks striped in WORD
Summary: FILESAVE: Gradient colored charts looks striped in WORD
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 09:22 UTC by szz
Modified: 2015-02-20 20:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
zipped odt,ods used for creating doc file (step1-2) plus saved doc file (step3) and as they seems on my machine on jpg-s (178.68 KB, application/zip)
2012-10-07 09:22 UTC, szz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description szz 2012-10-07 09:22:37 UTC
Created attachment 68196 [details]
zipped odt,ods used for creating doc file (step1-2) plus saved doc file (step3) and as they seems on my machine on jpg-s

Problem description: 
When I want to create a (97/2000/XP/2003)DOC file by Writer with charts that looks nice and gradient fill us used on them. The chart looks OK in LO but looks ugly in Word. 
( LO 3.6.1.2 Portable;MS Off 2003 Word). (strange but this is not a problem in case of CALC->EXCEL )

Steps to reproduce:
1. create chart in CALC and fill bars with gradient color
2. copy -paste chart to a new WRITER text document
3. save as 97/2000/XP/2003 Word DOC file
4. open it in Word

Current behavior:
While chart looks nice in LO in Word bars seems striped

Expected behavior:
should be shown in WORD as in LO

Platform (if different from the browser): 
XP prof. EN
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 A (Andy) 2013-03-02 13:57:48 UTC
reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

This issue (as reported) can be reproduced for many, but not for all gradient color combinations.  But in all cases a thin buggy border around the bars can be found.

I could reproduce it for the following combinations:
- Gradient 1
- Gradient 2
- Linear Blue/White
- Radial Red/Yellow
- Axial Light Red/White
- Linear Magenta/Green
- Linear Yellow/Brown

I could not reproduce it for the following combinations:
- Gradient 3
- Gradient 4
- Gradient 5
- Gradient 6
- Radial Green/Black
- Rectangular Red/White
- Square Yellow/White
- Ellipsoid Blue Gray/Light Blue

@Miklós: Could this maybe be an issue for you?
Comment 2 szz 2013-03-02 20:04:07 UTC
(In reply to comment #1)
> reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

Hi,
In that case shouldn't be changed the version to 4.0.0.3? 
Because it seems nobody (else) cares about it. But I think without solving such chart and compatibility issues LO is not the thing which can be the replacement of MSO.  :(  
Zoltan
Comment 3 A (Andy) 2013-03-02 20:44:41 UTC
I would propose to keep 3.6.1.2, even if I have reproduced it only now with LO 4.0.0.3, because this is the release, where it was reported the first time.  We should keep in this field the first release with the problem, so that programmers have the information about a regression and that they can track it back to the maybe last change before that bug was reported.
We have several other bugs, where we have the same situation and the many LO programmers are working hard to solve them, but of course it can take some time.
Comment 4 Miklos Vajna 2013-03-04 08:50:30 UTC
If this is a 3.6 -> 4.0 regression, please bibisect it:

https://wiki.documentfoundation.org/Bibisect

Thanks!
Comment 5 szz 2013-03-04 21:36:54 UTC
(In reply to comment #4)
> If this is a 3.6 -> 4.0 regression, please bibisect it:
> 
> https://wiki.documentfoundation.org/Bibisect
> 
> Thanks!


Hi,
From the link you have given:
"The bibisect is only possible for Bugs which are reproducible under Linux,"

Unfortunately I don't know if it is coming on Linux or not. I am afraid I cannot do it. Both of us use LO Win version as you see.

Could anyone else help us with this from this list, please?
BR Zoltan
Comment 6 QA Administrators 2015-02-19 15:48:52 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 7 A (Andy) 2015-02-20 20:23:42 UTC
No longer reproducible with LO 4.4.0.3, Win 8.1